CUDA Runtime not Updating to 12.1 on Jetson Xavier NX


I am having a problem with updating CUDA to 12.1 on my Jetson Xavier NX. I have the latest JetPack 5.1.1 installed with CUDA 11.4 runtime and SDK. I want to use one of the provided PyTorch Docker images provided by NVIDIA with CUDA 12.1. I followed this tutorial to update to CUDA 12.1, however, CUDA runtime stays on 11.4. I have added the compat directory to $LD_LIBRARY_PATH and ran deviceQuery. While CUDA driver states 12.1, my CUDA runtime is stuck at 11.4. When I run the Docker image, deviceQuery shows 11.4 for both driver and runtime.

I have tried to fix the issue for the past couple of days to no avail. I’d really appreciate it if someone could provide some help.

According to NVIDIA documentation both runtime and driver should be upgraded.

Thank you for the help.


Do you install the CUDA inside or outside the container?

On Jetson, the compatible container has a tag with l4t-pytorch.
For now, it doesn’t support CUDA 12.


I am referring to version 23.03 of this docker image.

Version 23.03 comes with CUDA 12. And I’m updating CUDA to 12.1 on the device itself. Though the runtime version of CUDA is stuck at 11.4. Does Docker rely on the host driver or runtime of CUDA?

Thank you.


The page is for the x86 or Arm SBSA user.

For Jetson, you will need an l4t package that can work with the L4T GPU driver.
However, we only support the default CUDA version in JetPack so the latest version is 11.4:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.