CUDA Toolkit Installation Problem

I have a K5000 in a Dell T7910 workstation that I want to use mainly with ffmpeg. I have tried this about 10 times on both RHEL 7.3 & CentOS 7.3 with no success.

I am able to install the 375.66 driver with not many problems. When I do the rpm install of CUDA per the NVIDIA installation page all goes well except that when I reboot after I run ‘yum install cuda’ the system will no longer boot. It hangs in different places such as loading Gnome, Postfix, etc.

I’m not sure what else I need to add other than I’ve updated everything before I tried to install the toolkit.

Any help will be greatly appreciated.

follow the instructions in the linux install guide:

http://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#abstract

  1. start over with a clean OS load
  2. read the install guide carefully, start to finish
  3. acknowledge that there are 2 different install methods (runfile and package manager) and you must not intermix the two
  4. Pick one of the 2 methods
  5. Get whatever installers you need from http://www.nvidia.com/getcuda
  6. perform all necessary steps, don’t skip any (e.g. nouveau removal)
  7. profit

If at any point in time, you decide to do system (OS) updates, and/or install a GPU driver separately from CUDA, acknowledge that these can be perilous activities if you don’t do it properly. Therefore it’s a good idea to learn the pitfalls before any such activities are undertaken.

Thank you txbob for the quick reply. I am reading the install guide while doing a clean install of RHEL.

I shall report back later.

There is joy in Mudville Yoda. Got it on the first pass.

Onward to building ffmpeg.

Much grass.