CUDA9.0 and cudnn7.6.5.32 on Lenovo T530, Win10 64bit

Lenovo T530, has Nvidia NVS 5400M and Intel HD graphics 4000, Win10 64 bit.
Use Geforce Experience to install driver 392.58.
CUDA 9.0 (cuda_9.0.176_win10_network.exe), cudnn 7.6.5.32 (cudnn-9.0-windows10-x64-v7.6.5.32.zip)

My paddlepaddle program complains no CUDA-capable device detected, when run check.
you may find some log in following.

My question is
is there any way for me to check cudnn?

paddle.fluid.install_check.run_check()
Running Verify Paddle Program …
2020-02-26 22:01:43,185-WARNING: You are using GPU version Paddle, But Your CUDA Device is not set properly

Error: cudaGetDeviceCount failed in paddle::platform::GetCUDADeviceCountImpl, error code : 38, Please see detail in https://docs.nvidia.com/cuda/cuda-runtime-api/group__CUDART__TYPES.html#group__CUDART__TYPES_1g3f51e3575c2178246db0a94a430e0038: no CUDA-capable device is detected at (D:\1.7.0\paddle\paddle\fluid\platform\gpu_info.cc:72)

C:\Program Files\NVIDIA Corporation\NVSMI>nvidia-smi
Wed Feb 26 22:34:21 2020
±----------------------------------------------------------------------------+
| NVIDIA-SMI 392.58 Driver Version: 392.58 |
|-------------------------------±---------------------±---------------------+
| GPU Name TCC/WDDM | Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 NVS 5400M WDDM | 00000000:01:00.0 N/A | N/A |
| N/A 48C P0 N/A / N/A | 61MiB / 1024MiB | N/A Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 Not Supported |
±----------------------------------------------------------------------------+

C:\Program Files\NVIDIA Corporation\NVSMI>nvidia-smi -q

==============NVSMI LOG==============

Timestamp : Wed Feb 26 22:35:01 2020
Driver Version : 392.58

Attached GPUs : 1
GPU 00000000:01:00.0
Product Name : NVS 5400M
Product Brand : GeForce
Display Mode : N/A
Display Active : N/A
Persistence Mode : N/A
Accounting Mode : N/A
Accounting Mode Buffer Size : N/A
Driver Model
Current : WDDM
Pending : WDDM
Serial Number : N/A
GPU UUID : GPU-8f8ab9b2-62a3-92ec-d8c9-e5275bb25861
Minor Number : N/A
VBIOS Version : 70.08.A8.03.02
MultiGPU Board : N/A
Board ID : N/A
GPU Part Number : N/A
Inforom Version
Image Version : N/A
OEM Object : N/A
ECC Object : N/A
Power Management Object : N/A
GPU Operation Mode
Current : N/A
Pending : N/A
GPU Virtualization Mode
Virtualization mode : N/A
PCI
Bus : 0x01
Device : 0x00
Domain : 0x0000
Device Id : 0x0DEF10DE
Bus Id : 00000000:01:00.0
Sub System Id : 0x21F517AA
GPU Link Info
PCIe Generation
Max : N/A
Current : N/A
Link Width
Max : N/A
Current : N/A
Bridge Chip
Type : N/A
Firmware : N/A
Replays since reset : N/A
Tx Throughput : N/A
Rx Throughput : N/A
Fan Speed : N/A
Performance State : P0
Clocks Throttle Reasons : N/A
FB Memory Usage
Total : 1024 MiB
Used : 54 MiB
Free : 970 MiB
BAR1 Memory Usage
Total : N/A
Used : N/A
Free : N/A
Compute Mode : Default
Utilization
Gpu : N/A
Memory : N/A
Encoder : N/A
Decoder : N/A
Encoder Stats
Active Sessions : N/A
Average FPS : N/A
Average Latency : N/A
Ecc Mode
Current : N/A
Pending : N/A
ECC Errors
Volatile
Single Bit
Device Memory : N/A
Register File : N/A
L1 Cache : N/A
L2 Cache : N/A
Texture Memory : N/A
Texture Shared : N/A
CBU : N/A
Total : N/A
Double Bit
Device Memory : N/A
Register File : N/A
L1 Cache : N/A
L2 Cache : N/A
Texture Memory : N/A
Texture Shared : N/A
CBU : N/A
Total : N/A
Aggregate
Single Bit
Device Memory : N/A
Register File : N/A
L1 Cache : N/A
L2 Cache : N/A
Texture Memory : N/A
Texture Shared : N/A
CBU : N/A
Total : N/A
Double Bit
Device Memory : N/A
Register File : N/A
L1 Cache : N/A
L2 Cache : N/A
Texture Memory : N/A
Texture Shared : N/A
CBU : N/A
Total : N/A
Retired Pages
Single Bit ECC : N/A
Double Bit ECC : N/A
Pending : N/A
Temperature
GPU Current Temp : 48 C
GPU Shutdown Temp : N/A
GPU Slowdown Temp : N/A
GPU Max Operating Temp : N/A
Memory Current Temp : N/A
Memory Max Operating Temp : N/A
Power Readings
Power Management : N/A
Power Draw : N/A
Power Limit : N/A
Default Power Limit : N/A
Enforced Power Limit : N/A
Min Power Limit : N/A
Max Power Limit : N/A
Clocks
Graphics : N/A
SM : N/A
Memory : N/A
Video : N/A
Applications Clocks
Graphics : N/A
Memory : N/A
Default Applications Clocks
Graphics : N/A
Memory : N/A
Max Clocks
Graphics : N/A
SM : N/A
Memory : N/A
Video : N/A
Max Customer Boost Clocks
Graphics : N/A
Clock Policy
Auto Boost : N/A
Auto Boost Default : N/A
Processes : N/A

I didn’t find any comments for error 38 in https://docs.nvidia.com/cuda/cuda-runtime-api/group__CUDART__TYPES.html#group__CUDART__TYPES_1g3f51e3575c2178246db0a94a430e0038

what does 38 mean?

PS: I’ve already doublechecked on the several time for cudnn files copy to right CUDA folder. It should be correct unless the package I downloaded is not correct.

nvs 5400m is a fermi device
The last CUDA toolkit that supported it is CUDA 8.0

GOT IT.
THANKS