cudaErrorMemoryAllocation just after CUDA installation

Hi to all!

I have just completed the installation of CUDA 11.3 on a fresh-installed Ubuntu 18.04 workstation.

I have followed all steps indicated in the Installation Guide Linux page, choosing the “deb (local)” method.

All installation steps has gone without any error, up to “ Running the Binaries”, to verify the correct CUDA installation.

While the deviceQuery utility runs correctly, when I execute bandwidthTest I get a cudaErrorMemoryAllocation message, and I can’t figure out what’s wrong.

Some detail:

Ubuntu 18.04.5 LTS (64-bit, kernel version: 5.4.0-73-generic)
cpu: Intel® Core™ i7-6700K CPU @ 4.00GHz
Memory: 32 GB

deviceQuery output:

CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 1 CUDA Capable device(s)

Device 0: “NVIDIA Quadro 410”
CUDA Driver Version / Runtime Version 11.3 / 11.3
CUDA Capability Major/Minor version number: 3.0
Total amount of global memory: 473 MBytes (495845376 bytes)
(001) Multiprocessors, (192) CUDA Cores/MP: 192 CUDA Cores
GPU Max Clock rate: 706 MHz (0.71 GHz)
Memory Clock rate: 891 Mhz
Memory Bus Width: 64-bit
L2 Cache Size: 131072 bytes
Maximum Texture Dimension Size (x,y,z) 1D=(65536), 2D=(65536, 65536), 3D=(4096, 4096, 4096)
Maximum Layered 1D Texture Size, (num) layers 1D=(16384), 2048 layers
Maximum Layered 2D Texture Size, (num) layers 2D=(16384, 16384), 2048 layers
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 49152 bytes
Total shared memory per multiprocessor: 49152 bytes
Total number of registers available per block: 65536
Warp size: 32
Maximum number of threads per multiprocessor: 2048
Maximum number of threads per block: 1024
Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
Max dimension size of a grid size (x,y,z): (2147483647, 65535, 65535)
Maximum memory pitch: 2147483647 bytes
Texture alignment: 512 bytes
Concurrent copy and kernel execution: Yes with 1 copy engine(s)
Run time limit on kernels: Yes
Integrated GPU sharing Host Memory: No
Support host page-locked memory mapping: Yes
Alignment requirement for Surfaces: Yes
Device has ECC support: Disabled
Device supports Unified Addressing (UVA): Yes
Device supports Managed Memory: Yes
Device supports Compute Preemption: No
Supports Cooperative Kernel Launch: No
Supports MultiDevice Co-op Kernel Launch: No
Device PCI Domain ID / Bus ID / location ID: 0 / 1 / 0
Compute Mode:
< Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 11.3, CUDA Runtime Version = 11.3, NumDevs = 1
Result = PASS

bandwidthTest output:

[CUDA Bandwidth Test] - Starting…
Running on…

Device 0: NVIDIA Quadro 410
Quick Mode

CUDA error at code=2(cudaErrorMemoryAllocation) “cudaMalloc((void **)&d_idata, memSize)”

I also tried to compile and run the example code showed in the An Even Easier Introduction to CUDA page, it is compiled correctly, but when I run the add_cuda executable I get only a Segmentation fault error message.

How to get out of this issue?
Any indication to help me solve the problem will be greatly appreciated.
Please let me know if any further information is needed.

Thanks in advance!