CuDF & Cuspatial installation for Jetson

Hello,

I’m wondering if anyone, or if someone @nvidia can share the complete steps for building CuDF and Cuspatial on any of the Jetson Devices.

I have tried to install these libraries many times, without any luck.

There are no guides available that actually work, i have tried the following guides/repos/gists. They do not work in 2022, on the latest l4t.

Any help, or pointers to get these libraries installed would be much appreciated.

Thank you.

Hi @rsc44, RAPIDS isn’t supported on Jetson, sorry about that. RAPIDS currently requires CUDA 11.5 for building the latest libraries, while JetPack 5.0 is on CUDA 11.4. Official support for Jetson is something we are looking into a roadmap for, but can’t provide a definitive commitment or timeline currently.

Hello @dusty_nv ,

I am aware that the latest branch of RAPIDS is not supported to CUDA 11.5 being required, i shoud have made that more clear.

I am not able to properly install the branch of CUDF “branch-0.19” that supports CUDA 10.1+.

Are you saying that branch will also not work on the latest jetpack/l4t (5.0) ?

I re-flashed one of my Xaviers to jetpack 4.5 so that i can try installing CuDF again.

I’ll log my steps, and let you know if i’m successful.

I’m not sure if it will work or not as it’s not officially supported on Jetson, but let us know if you are able to get it working with a bit of hacking, and I’m sure the community will appreciate it. Sorry to not be of more direct assistance as I’m not personally experienced with RAPIDS. You could try logging an issue on that GitHub if that helps.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.