cuDNN found but version can't be deduced

I keep getting the below cmake errors whenever I try to configure software.

  1. when trying build openpose 2. when build caffe.
  • Found cuDNN: ver. ??? found (include: /usr/include, library: /usr/lib/x86_64-linux-gnu/libcudnn.so)
    CMake Error at cmake/Cuda.cmake:227 (message):
    cuDNN version >3 is required.
    Call Stack (most recent call first):
    cmake/Cuda.cmake:255 (detect_cuDNN)
    cmake/Dependencies.cmake:85 (include)
    CMakeLists.txt:49 (include)

Hi @femifapo,
This looks the issue while installing cuDNN.
Can you please check the below link to validate if you are not missing on any step.
https://docs.nvidia.com/deeplearning/cudnn/install-guide/index.html

Thanks!

Hi,
I am not sure I am missing any step. It may be because of multiple installations.
I think a used the tar file method a while ago and debian file method recently.
How do I roll back installations so I can re-install? I on Ubuntu 18.04.

Thanks

Hi @femifapo,
You can have multiple installations simultaneously.
The most important things are having the LD_LIBRARY_PATH and PATH set to point to the correct installation.
Thanks!

Caffe doesn’t support cuDNN 8. Most libraries parse version information from cudnn.h. cuDNN 8 moved version information to a new header cudnn_version.h which breaks existing CMake scripts.

@YashasSamaga. Thank you very much for the insight. It will definitely save so much troubleshooting time.

@femifapo Hello, I met the exact same issue on you on openpose. When I try to cmake the openpose package, it raise the same error. I have tried cudnn 7.6.5 …

May I know how you fix that?

@chloridenitride . I never went back to fix that problem. I decided to use a different model (Posenet) which doesn’t require Caffe. I guess the solution would be to install the relevant previous version of cuDNN.

1 Like

May I know the repo that you using?

I have the same problem when building caffe. I am thinking of using older version of cudnn to overcome this version problem.

cheers

1 Like

Gotta love cmake.

in Openpose change the cmake/cuda.cmake file and the /cmake/modules/FindCuDNN.cmake file.

Find the line that reads:
file(READ {CUDNN_INCLUDE}/cudnn.h CUDNN_VERSION_FILE_CONTENTS) change to: file(READ {CUDNN_INCLUDE}/cudnn_version.h CUDNN_VERSION_FILE_CONTENTS)

2 Likes

Thank you!
It fixed the proble. :)

I also think so. I have wasted two days. I tried both .run and .deb packages to install cudnn-8.0. Is there any update to install caffe with cuda-10.2 and cudnn 8.0?

Are you able to build caffe using older version of cuDNN? if yes then may I ask about your cudNN version?

Hello @asadjavedgujar, unfortunately I couldn’t. Freezed my work on caffe installation I will keep working on it in the future unless someone find a solution for that.

Update: I found a docker image for caffe on tx2. It might work.

1 Like