cuDNN support for Tesla M2090

Does any of the version of cuDNN supports Tesla M2090 ?

No. cuDNN requires a compute capability 3.0 or higher. This has been true for all versions of cuDNN so far. M2090 is compute capability 2.0.

This reference indicates that even the cuDNN v1 user guide reported the requirement for cc3.0:

https://github.com/botonchou/libdnn/issues/20

Is there any possibility to get it supported by cuDNN ? .

No.