Debuggable OptiX-IR makes launching a pipeline failed

Hello,

I have been updating my programs to use OptiX-IR whenever possible, but OptiX-IR still makes some program not working.

This is like the old issue:

but the old issue seemed resolved once and now the error message is different. So let me create the new ticket.

I have a repro for this issue.
repro_optixir_work_to_rtx.zip
Open samples\repro_optixir_work_to_rtx.sln.

The program crashes only with debug build at the line 1923:
pipeline.launch(curStream, plpOnDevice, renderTargetSizeX, renderTargetSizeY, 1);

The error message is

[ 2][       ERROR]: Error syncing stream (CUDA error string: unspecified launch failure, CUDA error code: 719)
Error launching work to RTX
Error recording resource event on user stream (CUDA error string: unspecified launch failure, CUDA error code: 719)

This is obviously not helpful.

Could you take a look what is happening inside the OptiX runtime?

Thanks,

Windows 11 Pro 23H2, 22631.2715
Visual Studio Community 2022, 17.8.2
OptiX 8.0.0
CUDA 12.2 Update 2
Ryzen 9 7950X
RTX 4080
Driver: 546.17

Thanks for the reproducer project. I could reproduce the launch failure with the debug target and filed a bug report about it.

The OptiX validation mode threw some warnings which you can easily solve inside your source code, but that didn’t change the behavior.
There were warnings about inlined functions which can be solved by adding the respective __forceinline__ define:

  • Add CUDA_INLINE to void decodeHitPoint().
  • Add RT_INLINE to all member functions inside class DirectCallableProgramID and class ContinuationCallableProgramID.
  • There was a warning about double precision computations inside optix_kernels.cu which came from the double M_PI definition.
    Changing that to #define M_PIf 3.14159265f and using that instead will be faster.
  • There was also a “Warning: Could not instrument function __exception__print for debugging. No suitable insertion point found.” which can be solved by uncommenting your user defined exception program for debug targets.
1 Like

It seems this issue is still there with the driver 551.23.

Yes, this isn’t fully solved, yet.

1 Like