DeepStream 4.0 EA fails to run on JetPack 4.2.1 GA

Hi,

Having seen the announcement of JetPack 4.2.1 GA release,
I have replaced JetPack 4.2.1 EA with JetPack 4.2.1 GA.

Then, I found nvinfer won’t run anymore.

For example, deepstream-test1 fails as follows:

Xavier

deepstream_sdk_on_jetson/sources/apps/sample_apps/deepstream-test1$ ./deepstream-test1-app ../../../../samples/streams/sample_720p.h264 
Unknown key 'parse-func' for group [property]
Now playing: ../../../../samples/streams/sample_720p.h264

Using winsys: x11 
Opening in BLOCKING MODE 
Creating LL OSD context new
0:00:01.061567650 29051   0x55655b4730 INFO                 nvinfer gstnvinfer.cpp:519:gst_nvinfer_logger:<primary-nvinference-engine> NvDsInferContext[UID 1]:initialize(): Trying to create engine from model files
0:00:40.376531335 29051   0x55655b4730 INFO                 nvinfer gstnvinfer.cpp:519:gst_nvinfer_logger:<primary-nvinference-engine> NvDsInferContext[UID 1]:generateTRTModel(): Storing the serialized cuda engine to file at /home/emi/projects/deepstream_sdk_on_jetson/samples/models/Primary_Detector/resnet10.caffemodel_b1_int8.engine
nvbufsurface: memory type (-2145384446) not supported
0:00:40.416460734 29051   0x55655b4730 WARN                 nvinfer gstnvinfer.cpp:773:gst_nvinfer_start:<primary-nvinference-engine> error: Failed to set buffer pool to active
Running...
ERROR from element primary-nvinference-engine: Failed to set buffer pool to active
Error details: /dvs/git/dirty/git-master_linux/deepstream/sdk/src/gst-plugins/gst-nvinfer/gstnvinfer.cpp(773): gst_nvinfer_start (): /GstPipeline:dstest1-pipeline/GstNvInfer:primary-nvinference-engine
Returned, stopping playback
Deleting pipeline

TX2

deepstream_sdk_on_jetson/sources/apps/sample_apps/deepstream-test1$ ./deepstream-test1-app ../../../../samples/streams/sample_720p.h264 
Unknown key 'parse-func' for group [property]
Now playing: ../../../../samples/streams/sample_720p.h264

Using winsys: x11 
Opening in BLOCKING MODE 
Creating LL OSD context new
0:00:02.555543306 31982   0x5585015730 INFO                 nvinfer gstnvinfer.cpp:519:gst_nvinfer_logger:<primary-nvinference-engine> NvDsInferContext[UID 1]:initialize(): Trying to create engine from model files
0:00:02.556668653 31982   0x5585015730 WARN                 nvinfer gstnvinfer.cpp:515:gst_nvinfer_logger:<primary-nvinference-engine> NvDsInferContext[UID 1]:generateTRTModel(): INT8 not supported by platform. Trying FP16 mode.
0:00:44.125731956 31982   0x5585015730 INFO                 nvinfer gstnvinfer.cpp:519:gst_nvinfer_logger:<primary-nvinference-engine> NvDsInferContext[UID 1]:generateTRTModel(): Storing the serialized cuda engine to file at /home/emi/projects/deepstream_sdk_on_jetson/samples/models/Primary_Detector/resnet10.caffemodel_b1_fp16.engine
nvbufsurface: memory type (-2145384446) not supported
0:00:44.207355800 31982   0x5585015730 WARN                 nvinfer gstnvinfer.cpp:773:gst_nvinfer_start:<primary-nvinference-engine> error: Failed to set buffer pool to active
Running...
ERROR from element primary-nvinference-engine: Failed to set buffer pool to active
Error details: /dvs/git/dirty/git-master_linux/deepstream/sdk/src/gst-plugins/gst-nvinfer/gstnvinfer.cpp(773): gst_nvinfer_start (): /GstPipeline:dstest1-pipeline/GstNvInfer:primary-nvinference-engine
Returned, stopping playback
Deleting pipeline

The error message, nvbufsurface: memory type (-2145384446) not supported, is new to me.

I can’t find through gst-inspect, but is there any new setting introduced?
Or I have to wait until DeepStream 4.0 is released?

Thanks.

Hi TakenoriSato,

This is expected not to work .
Please wait for Deepstream GA release . EA release is not compatible with JP 4.2.1 public release .

Thanks

OK, thanks for your confirmation.

how to doweload deepstream 4.0?or what time for release 4.0 GA?

Contact your local NVIDIA guy, and get your registration done.

As mentioned below, in July 2019. Soon.

https://devtalk.nvidia.com/default/topic/1055629/announcements/new-jetson-software-modules-and-pricing/post/5351648/#5351648