DeepStream 6.4 is now available for download!

DeepStream 6.4 is out now supporting Ubuntu 22.04, JetPack 6.0 and GStreamer 1.20.3!

This release is packed with new features and improvements such as:
New Single-View 3D tracking capability available on NvTracker.
NvDCF tracker now supported with PVA backend on Jetson devices.
Support for AV1 encoder.
Two new plugins for image decoding and encoding.
And more!

Check all the details:


We got the segment core dump when try uridecodebin source with setting protocols rtsp tcp (4).

we had tried to install the ffmpeg (apt-get install ffmpeg) inside docker deepstream v6.4 also give the segment core dump. the debug tool only show the exception above the av function ffmpeg av_opt_child_class_iterate coredump. I am not sure what is the main problem?
the command we tried:
ffproble -rtsp_transport tcp -i "rtsp_stream_url"

is there a single 3d view tracking demo?

Currently there is no such demo. We will consider the request.

Ok. That’s what I expect

We didn’t find this issue, please file a new topic with your setup and testing steps attached, thank you.

Since it is a brand-new feature, we are preparing to provide more info/details about Single-View 3D Tracking. Please stay tuned.

Has the bug NvMultiurisrcbin doesn't set gpu-id - #5 by Levi_Pereira resolved? I couldn’t find any information about it."

Yes. It’s resolved. You can try that with DeepStream 6.4.

1 Like

NVIDIA DeepStream SDK Developer Guides

1 Like

where can I download deepstream-6.2 now?
I can’t find it anywhere

The link to archived SDK can be found on the link: DeepStream SDK FAQ - #35 by Fiona.Chen, DeepStream 6.2 download link can be found on page Quickstart Guide — DeepStream 6.2 Release documentation (

There is an issue on using a .engine file inside a tracker ReID section.

In 6.3 config_tracker_xxx.yml, if providing onnxFile or uffFile, a corresponding engine file will be created, similar to model.onnx_b100_gpu0_fp32.engine. Then set path in modelEngineFile, the engine file can be used in future. For example:
modelEngineFile: “/path/to/the/engine/file/converted/internally/or/externally.engine”

In 6.4, if providing a uff or onnx file, the experiment could run in the first time, and a .engine file will be create like previous, however, this .engine cannot be used while setting the modelEngineFile. Here is the error message:
[NvMultiObjectTracker] Loading TRT Engine for tracker ReID…
[NvMultiObjectTracker] Loading Complete!
Aborted (core dumped)

It seems the tracker ReID does not support a engine file properly in 6.4, but it always took some time to create a useless engine file in every call. I have tested the engine file in tracker ReID for both DeepSORT and DCF, both not working. This issue only related to engine file in ReID. Other engine models, for example, converted from onnx-file or provided by model-engine-file in a .txt like a detection model, still works fine.

Please file a new topic for this issue, thank you.

JetPack 6.0 and Jetson Linux 36.2 When will they be released?