Deepstream on PC

I pulled docker deepstream and run on my PC by this: https://ngc.nvidia.com/catalog/containers/nvidia:deepstream
But I can’t run deepstream-app in this docker.
The error display:
ERROR: main:655: Failed to set pipeline to PAUSED

I run again with command line:
gst-launch-1.0 filesrc location=/opt/nvidia/deepstream/deepstream-5.0/samples/streams/sample_720p.mp4 ! qtdemux ! h264parse ! nvv4l2decoder ! m.sink_0 nvstreammux name=m batch-size=1 width=1280 height=720 ! nvvideoconvert ! dsexample full-frame=0 ! nvdsosd ! nvoverlaysink

This command run ok on Jetson TX2, but when run on PC, i got :
WARNING: erroneous pipeline: no element "nvoverlaysink"

The question is, how can i run deepstream-app on PC? Should I change others sink mode?
My PC’s using GTX 1650

• Hardware Platform (Jetson / GPU) PC, GeForce GTX 1650
• DeepStream Version 5.0
• JetPack Version (valid for Jetson only) 4.4
• TensorRT Version 7.1
• NVIDIA GPU Driver Version (valid for GPU only) 10.2

nvoverlaysink is for Jetson platform only.
With “PC” side, the nveglglessink is recommanded by DeepStream. Please refer to the DeepStream samples.