How to use nveglglessink(deepstream) on my pc?

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
GPU
• DeepStream Version
5.0
• JetPack Version (valid for Jetson only)
• TensorRT Version
7.0
• NVIDIA GPU Driver Version (valid for GPU only)
440

On my pc (ubuntu 18.04), I think there should be no problem with xserver. However, when I use nveglglessink to render the results on GUI, it raised this error:
ERROR from secondary_gie_bin_queue: Internal data stream error.
Debug info: gstqueue.c(988): gst_queue_handle_sink_event (): /GstPipeline:pipeline/GstBin:secondary_gie_bin/GstQueue:secondary_gie_bin_queue:
streaming stopped, reason not-negotiated (-4)

this command I used: deepstream-app -c /opt/nvidia/deepstream/deepstream-5.0/samples/configs/deepstream-app/source4_1080p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt

the cuda info:

How do you render with nveglglessink? With command line? Or with deepstream-app? Did you run in docker or directly with your PC?

yes, with command line: deepstream-app -c /opt/nvidia/deepstream/deepstream-5.0/samples/configs/deepstream-app/source4_1080p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt

with deepstream-app

I tried docker conatainer firstly, it didnt work. Then I tried on my PC directly, with the similar error.

Have you installed Nvidia OpenGL correctly? OpenGL | NVIDIA Developer. Can you reinstall the openGL driver? It may has nothing to do with deepstream.

1 Like

many thanks, I reinstalled opengl driver and it worked.