Deepstream python programs run fail on X86 platform

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) dGPU RTX 2060
• DeepStream Version deepstream 5.1
• JetPack Version (valid for Jetson only)
• TensorRT Version 7.2.3
• NVIDIA GPU Driver Version (valid for GPU only) 460.32
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

I’m moving Deepstream python programs from Jetson Xavier NX to X86 platform. I tried 2 Deepstream python programs on X86, and both run error, but they can run on Jetson well.

  1. program No.1, just deepstream-python-app test1. I didn’t modify the code of it.
    The screenshot of error is below:

  1. program No.2. I use TLT Peoplenet34 model, and also failed.
    The screenshot of error is below:

How can solve it, many thanks.

hello everyone, may I get anyone’s help? many thanks.

Can you run gst-launch-1.0 videotestsrc ! nveglglessink?
you can run from desktop or you can run through remote terminal by exporting DISPLAY,
export DISPLAY=:0 or 1 //xrandr to check if display exported

sure, I’ve run gst-launch-1.0 videotestsrc ! nveglglessink, and it seems work, pls. see below screenshot.

many thanks.

Can you specify how you install the display driver?

@amycao Hi Amy,

about the installation of display driver, I use runfile NVIDIA-Linux-x86_64-460.32.03.run, due to filed to install the 460.32 runfile at the very first, I went for below steps.

  1. Install dependency.

sudo apt-get update
sudo apt-get install dkms build-essential linux-headers-generic
sudo apt-get install gcc-multilib xorg-dev
sudo apt-get install freeglut3-dev libx11-dev libxmu-dev install libxi-dev libgl1-mesa-glx libglu1-mesa libglu1-mesa-dev

  1. Disabled the nouveau

sudo vi /etc/modprobe.d/blacklist-nouveau.conf
#add below into file blacklist-nouveau.conf
blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off
alias lbm-nouveau off
#save :wq

#disable nouveau
echo options nouveau modeset=0 | sudo tee -a /etc/modprobe.d/nouveau-kms.conf
sudo update-initramfs -u
reboot

  1. install 460.32 driver

sudo sh ./NVIDIA-Linux-x86_64-460.32.03.run --no-opengl-files

  1. about the questions during installation, I all chose the default answers

I don’t know if the default questions choises are correct, many thanks.

@amycao Hi amy,

BTW, I also run “deepstream-app -c deepstream_app_config_yoloV3_tiny.txt” command, and the error is “Internal data stream error” , same as python deppstream-test1 app.

I saw there is error below.
Could you try to add “sudo” before deepstream command to run with root permission?

@mchi Hi,

I added “sudo” before python3 and deepstream command, but it still didn’t work, run same error as before.

Fromn the first lo, there is not the error as below.

And, looks it has run successfully, why “same error”?

Regarding below error, you need to check if your display is running on GPU.

you can run “nvidia-smi” and share the output

“same error” means the error are both “internal data stream error”, and the app did run failed.

“nvidia-smi” result listed below.

there is error - “cudagraphicsglregisterbuffer failed with error 304”, seems the same as cuGraphicsGLRegisterBuffer failed with error(304) gst_eglglessink_cuda_init texture =1 - #12 by amycao

You could refer to Installation Guide Linux :: CUDA Toolkit Documentation to install the driver

@amycao @mchi Hi,

I’ve refer cuGraphicsGLRegisterBuffer failed with error(304) gst_eglglessink_cuda_init texture =1 - #12 by amycao .

I just re-installed the nvidia 460.32 driver, and chose ‘yes’ when “setup nvidia x config”, but it still does not work, and the error same as before.

please remove option --no-opengl-files when you isntall driver.

@amycao @mchi Hi,

I changed the gstreamer pipeline of python deepstream-test1 from nvosd → nveglglessink to nvosd → nvvidconv → xvimagesink, then the program run well on my X86 laptop.

The problem maybe happened on the nveglglessink element, and maybe some related libs are not linked.

I will keep trying to move my others python deepstream programs from Jetson to X86 platform.

Can you pls. kindly help to give me some tips about the root cause?

many thanks.

xvimagesink is CPU based plugin, while nveglglessink is GPU based .

So, I think it’s still some issue with your GPU driver