Deepstream_test1_app failed

• Hardware Platform (Jetson AGX Orin Developer Kit)
• DeepStream Version - 6.2.0
• JetPack Version - 5.1.1-b56
• TensorRT Version - 8.5
• NVIDIA GPU Driver Version (valid for GPU only) - don’t know how to find this
• Issue Type( questions)
• How to reproduce the issue ? (command line)
• Requirement details( Run test1 for a Hello World understanding)
• Camera - HD Pro Webcam C920
• Monitor - MSI

I followed the README instructions (/opt/nvidia/deepstream/deepstream-6.2/sources/apps/sample_apps/deepstream-test1) after completing Quickstart.html (Quickstart Guide — DeepStream 6.2 Release documentation). All has installed & compiled as expected.

At /opt/nvidia/deepstream/deepstream-6.2/sources/apps/sample_apps/deepstream-test1 I ran
~$ ./deepstream-test1-app dstest1_config.yml
Added elements to bin
Using file: dstest1_config.yml
ERROR from element nv3d-sink: GStreamer error: state change failed and some element failed to post a proper error message with the reason for the failure.
Error details: gstbasesink.c(5367): gst_base_sink_change_state (): /GstPipeline:dstest1-pipeline/GstNv3dSink:nv3d-sink:
Failed to start
Returned, stopping playback
Deleting pipeline

At this point I’m a novice with Deepstream and need some hints on how to run code without this error. I have been working with GStreamer & Jetson Inference for a while.
I see in the README under “.4 Usage:” the comments about “user needs to modify the source code” and
“user needs to update yml”. I have no idea what changes are needed per this statement. I ran the code as is.

Help would be appreciated to get me going. In addition, pointing me to other forum questions and/or training I could take to get hands on coding understanding to Deepstream would be appreciated. I’m past the theory stuff…


This is for dGPU.For Jetson, run deepstream-app --version-all or jetson_release can got information which your need.

Is your device plugged into the monitor? This error is usually caused by headless.
If you have a monitor,export DISPLAY=:0.0 then run the demo app, It will be ok.
If not,try modify nv3dsink to fakesink

Usually most of the problems are explained in detail in the DeepStream documentation.
Any questions will be answered here.


Closed terminal and re-opened a new terminal window.
~$ cd /opt/nvidia/deepstream/deepstream-6.2/sources/apps/sample_apps/deepstream-test1
~$ printenv
~$ ./deepstream-test1-app dstest1_config.yml

Application worked. People and cars show on video.

Don’t know why it runs now and not before.

I see the DISPLAY=:1. However, ~$ xrandr -q shows
Screen 0: …
DP-0 connected primary
DP-1 disconnected

Why would DISPLAY environment variable be 1 and xrandr show 0?

Thanks for the suggestions.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.