deepstream SDK - RTSP error

I’m trying the “deepstream test3” example an rtsp address of an ip camera that transmits in h264.
I get this error:

nvidia@nvidia-desktop:~/deepstream_sdk_on_jetson/sources/apps/sample_apps/deepstream-test3$ ./deepstream-test3-app rtsp://admin:Passw0rd@192.168.30.61/Streaming/Channels/101/
WARNING: Overriding infer-config batch-size (2) with number of sources (1)
Now playing: rtsp://admin:Passw0rd@192.168.30.61/Streaming/Channels/101/,
>>> Using TRT model serialized engine /home/nvidia/deepstream_sdk_on_jetson/sources/apps/sample_apps/deepstream-test3/../../../../samples/models/Primary_Detector/resnet10.caffemodel_b2_int8.engine crypto flags(0)
Running...
NvMMLiteOpen : Block : BlockType = 261 
NVMEDIA: Reading sys.display-size : status: 6 
NvMMLiteBlockCreate : Block : BlockType = 261 
Allocating new output: 1280x720 (x 13), ThumbnailMode = 0
OPENMAX: HandleNewStreamFormat: 3595: Send OMX_EventPortSettingsChanged: nFrameWidth = 1280, nFrameHeight = 720 
nvstreamtiler: batchSize set as 1
buf_convert: Wrong src surface count in ConvertBuffer

Any solution? thank you

Hi,
Please try
https://devtalk.nvidia.com/default/topic/1050634/deepstream-sdk-on-jetson/deepstream-3-0-question-about-quot-deepstream-test3-app-rtst-quot-on-xavier/post/5332407/#5332407

Thanks.

If i try:

gst-launch-1.0 rtspsrc location=rtsp://admin:pass@192.168.30.61/Streaming/Channels/102/ ! rtph264depay ! h264parse ! omxh264dec ! nvoverlaysink

It works.

I’ve tried to modify “deepstream_test_3_app.c” with your tips.

But I always get the same error, I’m sure I’m wrong in editing the .c file.
Can you send me the “deepstream_test_3_app.c” file already modified?

Thanks

Hi,
Please refer to below post which runs udpsrc:
https://devtalk.nvidia.com/default/topic/1051847/jetson-agx-xavier/deepstream-3-0-c-api/post/5340185/#5340185
It should be similar to your case.

I’m sorry but I didn’t understand what to change, could I have further explanations?
I would like to pass an rtsp:// link, instead of a h264 file.

Thanks

Hi,
We encourage users to do integration. lilei6 has worked out a solution in 1050634. You may contact him for suggestion.