could not play RTSP stream with deepstream_sdk_v4.0.1_jetson\sources\apps\sample_apps\deepstream-test3 sample

Hi:
On Jetson Xavier, I have upgraded Jetpack 4.2(newest) by SDK manager, install DeepStream SDK 4.0.1 and dependent tools as well.
Now trying to run the sample application, I ran some samples successfully, while some not. For example deepstream-test3 sample, I am able to read file and analyze car and pedestrian in it. I tried to parse rstp stream, but it failed ( rtsp://admin:abc.1234@10.10.21.108/cam/realmonitor?channel=1&subtype=0 stream is able to play by VLC ). Here is the debug message as below. Please kind advice.


nvidia@nvidia-desktop:~/samba/source/deepstream_sdk_v4.0.1_jetson/sources/apps/sample_apps/deepstream-test3$ ./deepstream-test3-app rtsp://admin:abc.1234@10.10.21.108/cam/realmonitor?channel=1&subtype=0
[1] 17620
nvidia@nvidia-desktop:~/samba/source/deepstream_sdk_v4.0.1_jetson/sources/apps/sample_apps/deepstream-test3$ Now playing: rtsp://admin:abc.1234@10.10.21.108/cam/realmonitor?channel=1,

Using winsys: x11
Creating LL OSD context new
0:00:00.579794304 17620 0x558de84e40 INFO nvinfer gstnvinfer.cpp:519:gst_nvinfer_logger: NvDsInferContext[UID 1]:initialize(): Trying to create engine from model files
0:00:26.423353962 17620 0x558de84e40 INFO nvinfer gstnvinfer.cpp:519:gst_nvinfer_logger: NvDsInferContext[UID 1]:generateTRTModel(): Storing the serialized cuda engine to file at /home/nvidia/samba/source/deepstream_sdk_v4.0.1_jetson/samples/models/Primary_Detector/resnet10.caffemodel_b1_int8.engine
Decodebin child added: source
Running…
ERROR from element source: Not found
Error details: gstrtspsrc.c(6112): gst_rtspsrc_send (): /GstPipeline:dstest3-pipeline/GstBin:source-bin-00/GstURIDecodeBin:uri-decode-bin/GstRTSPSrc:source:
Not Found (404)
Returned, stopping playback
Deleting pipeline

Does it not like the & in the camera URL?? The error message hem as chopped off the URL from the &. Maybe you need to wrap it in quotes?
Either that if you accidentally didn’t copy and paste that bit. The issue is something to do with the source URL though…

Dear jasonpgf2a:
Very thanks for your advice.
Just as your advice, wrapping the rtsp address in quotes works.