Deepstream-test1.yaml - Could not create GStreamer element 'nvurisrcbin' - what to be done?

Please provide complete information as applicable to your setup.

• Hardware Platform GPU
• DeepStream Version 6.1.1
• TensorRT Version
• NVIDIA GPU Driver Version 515.48.7
• Issue Type( question)

• “deepstream-test1” from reference_graphs → error

It seems, that an extension has to be installed.
Before that I successfully generated and built v4l2src.

Do I have to generate and build another one to get the reference_graph executed?

Regards
Stefan

stefan@ubuntu20:~$ 2022-09-07 18:13:38,445 - Composer - INFO - Running graph /opt/nvidia/deepstream/deepstream-6.1/reference_graphs/deepstream-test1/deepstream-test1.yaml
2022-09-07 18:13:38,447 - Composer - INFO - Validating the graph...
2022-09-07 18:13:38,448 - Composer - INFO - Saving model: /opt/nvidia/deepstream/deepstream-6.1/reference_graphs/deepstream-test1/deepstream-test1.yaml
2022-09-07 18:13:38,496 - Composer - INFO - Graph successfully saved.
Graphs: deepstream-test1.yaml
Target: /opt/nvidia/graph-composer/config/target_x86_64.yaml
===================================================================
Running deepstream-test1.yaml
===================================================================
[INFO] Writing manifest to /tmp/ds.deepstream-test1/manifest.yaml 
2022-09-07 18:13:38.529 INFO  gxf/gxe/gxe.cpp@230: Creating context
2022-09-07 18:13:38.546 INFO  gxf/gxe/gxe.cpp@107: Loading app: '/opt/nvidia/deepstream/deepstream-6.1/reference_graphs/deepstream-test1/deepstream-test1.yaml'
2022-09-07 18:13:38.546 INFO  gxf/std/yaml_file_loader.cpp@117: Loading GXF entities from YAML file '/opt/nvidia/deepstream/deepstream-6.1/reference_graphs/deepstream-test1/deepstream-test1.yaml'...
2022-09-07 18:13:38.548 INFO  gxf/gxe/gxe.cpp@291: Initializing...
2022-09-07 18:13:38.561 INFO  extensions/nvdsbase/nvds_scheduler.cpp@265: This program is linked against GStreamer 1.16.3

2022-09-07 18:13:38.562 INFO  extensions/nvdssource/nvurisrcbin.hpp@24: initialize: nvurisrcbin nv_ds_single_src_input3..c518

2022-09-07 18:13:38.562 INFO  extensions/nvdsmuxdemux/nvstreammux.hpp@27: initialize: nvstreammux nv_ds_stream_mux6..db00

2022-09-07 18:13:38.562 INFO  extensions/nvdsinference/nvinferbin.hpp@24: initialize: nvinferbin nv_ds_infer10..2748

2022-09-07 18:13:38.562 INFO  extensions/nvdsvisualization/nvosdbin.hpp@24: initialize: nvosdbin nv_ds_osd14..5978

2022-09-07 18:13:38.562 INFO  extensions/nvdsoutputsink/nvvideorenderersinkbin.hpp@24: initialize: nvvideorenderersinkbin nv_ds_video_renderer18..d2b0

2022-09-07 18:13:38.563 INFO  gxf/gxe/gxe.cpp@298: Running...
2022-09-07 18:13:38.563 INFO  extensions/nvdsbase/nvds_scheduler.cpp@116: Scheduling 5 elements and 1 components
2022-09-07 18:13:38.563 INFO  extensions/nvdssource/nvurisrcbin.hpp@32: create_element: nvurisrcbin nv_ds_single_src_input3..c518

*******************************************************************
End deepstream-test1.yaml
*******************************************************************
[INFO] Graph installation directory /tmp/ds.deepstream-test1 and manifest /tmp/ds.deepstream-test1/manifest.yaml retained 
2022-09-07 16:13:38 [346,346ms] [Error] [omni.kit.app.impl] [py stderr]: 2022-09-07 18:13:38.563 ERROR extensions/nvdssource/nvurisrcbin.hpp@36: Could not create GStreamer element 'nvurisrcbin'
2022-09-07 18:13:38.563 ERROR extensions/nvdssource/nvurisrcbin.hpp@36: Could not create GStreamer element 'nvurisrcbin'2022-09-07 16:13:38 [346,346ms] [Error] [omni.kit.app.impl] [py stderr]: 


2022-09-07 16:13:38 [346,346ms] [Error] [omni.kit.app.impl] [py stderr]: 2022-09-07 18:13:38.563 ERROR gxf/std/program.cpp@337: Couldn't run async. Deactivating...
2022-09-07 18:13:38.563 ERROR gxf/std/program.cpp@337: Couldn't run async. Deactivating...2022-09-07 16:13:38 [346,346ms] [Error] [omni.kit.app.impl] [py stderr]: 


2022-09-07 16:13:38 [346,346ms] [Error] [omni.kit.app.impl] [py stderr]: 2022-09-07 18:13:38.563 ERROR gxf/core/runtime.cpp@1166: Graph run failed with error: GXF_FAILURE
2022-09-07 18:13:38.563 ERROR gxf/core/runtime.cpp@1166: Graph run failed with error: GXF_FAILURE2022-09-07 16:13:38 [346,346ms] [Error] [omni.kit.app.impl] [py stderr]: 


2022-09-07 16:13:38 [346,346ms] [Error] [omni.kit.app.impl] [py stderr]: 2022-09-07 18:13:38.563 ERROR gxf/gxe/gxe.cpp@301: GxfGraphRunAsync Error: GXF_FAILURE
2022-09-07 18:13:38.563 ERROR gxf/gxe/gxe.cpp@301: GxfGraphRunAsync Error: GXF_FAILURE2022-09-07 16:13:38 [346,346ms] [Error] [omni.kit.app.impl] [py stderr]:

Seems your DeepStream SDK is not installed correctly. Please follow Quickstart Guide — DeepStream 6.1.1 Release documentation to install DeepStream SDK 6.1.1 GA correctly.

I just used container builder to create deepstream_test1_dgpu and when I try to run that container I will get the same error. I use container builder from official docker image (6.1.1), so I assume that there are some packages missing from SDK. Can you follow up that those packages are added to SDK?

Please submit new topic with environment/logs for the issue you mention, thanks.