Deepstream6.1 docker deploy yolox

WARNING: [TRT]: TensorRT was linked against cuBLAS/cuBLAS LT 11.5.1 but loaded cuBLAS/cuBLAS LT 110.9.2
WARNING: [TRT]: TensorRT was linked against cuBLAS/cuBLAS LT 11.5.1 but loaded cuBLAS/cuBLAS LT 110.9.2
0:00:01.164178283 173 0x557a3ccca100 INFO nvinfer gstnvinfer.cpp:638:gst_nvinfer_logger:<primary_gie> NvDsInferContext[UID 1]: Info from NvDsInferContextImpl::deserializeEngineAndBackend() <nvdsinfer_context_impl.cpp:1900> [UID = 1]: deserialized trt engine from :/opt/nvidia/deepstream/deepstream-6.0/sources/objectDetector_Yolo/s.trt
INFO: …/nvdsinfer/nvdsinfer_model_builder.cpp:610 [Implicit Engine Info]: layers num: 2
0 INPUT kFLOAT images 3x640x1024
1 OUTPUT kFLOAT output 13440x15

0:00:01.164270516 173 0x557a3ccca100 INFO nvinfer gstnvinfer.cpp:638:gst_nvinfer_logger:<primary_gie> NvDsInferContext[UID 1]: Info from NvDsInferContextImpl::generateBackendContext() <nvdsinfer_context_impl.cpp:2004> [UID = 1]: Use deserialized engine model: /opt/nvidia/deepstream/deepstream-6.0/sources/objectDetector_Yolo/s.trt
0:00:01.172815089 173 0x557a3ccca100 INFO nvinfer gstnvinfer_impl.cpp:313:notifyLoadModelStatus:<primary_gie> [UID 1]: Load new model:/opt/nvidia/deepstream/deepstream-6.0/sources/objectDetector_Yolo/config_infer_primary0.txt sucessfully

Runtime commands:
h: Print this help
q: Quit

p: Pause
r: Resume

**PERF: FPS 0 (Avg)
**PERF: 0.00 (0.00)
** INFO: <bus_callback:194>: Pipeline ready

** INFO: <bus_callback:180>: Pipeline running

ERROR from sink_sub_bin_encoder1: Could not get/set settings from/on resource.
Debug info: gstv4l2object.c(3501): gst_v4l2_object_set_format_full (): /GstPipeline:pipeline/GstBin:processing_bin_0/GstBin:sink_bin/GstBin:sink_sub_bin1/nvv4l2h264enc:sink_sub_bin_encoder1:
Device is in streaming mode
ERROR from sink_sub_bin_encoder1: Could not get/set settings from/on resource.
Debug info: gstv4l2object.c(3501): gst_v4l2_object_set_format_full (): /GstPipeline:pipeline/GstBin:processing_bin_0/GstBin:sink_bin/GstBin:sink_sub_bin1/nvv4l2h264enc:sink_sub_bin_encoder1:
Device is in streaming mode
ERROR from sink_sub_bin_encoder1: Could not get/set settings from/on resource.
Debug info: gstv4l2object.c(3501): gst_v4l2_object_set_format_full (): /GstPipeline:pipeline/GstBin:processing_bin_0/GstBin:sink_bin/GstBin:sink_sub_bin1/nvv4l2h264enc:sink_sub_bin_encoder1:
Device is in streaming mode
ERROR from sink_sub_bin_encoder1: Could not get/set settings from/on resource.
Debug info: gstv4l2object.c(3501): gst_v4l2_object_set_format_full (): /GstPipeline:pipeline/GstBin:processing_bin_0/GstBin:sink_bin/GstBin:sink_sub_bin1/nvv4l2h264enc:sink_sub_bin_encoder1:
Device is in streaming mode
ERROR from sink_sub_bin_encoder1: Could not get/set settings from/on resource.
Debug info: gstv4l2object.c(3501): gst_v4l2_object_set_format_full (): /GstPipeline:pipeline/GstBin:processing_bin_0/GstBin:sink_bin/GstBin:sink_sub_bin1/nvv4l2h264enc:sink_sub_bin_encoder1:
Device is in streaming mode
ERROR from sink_sub_bin_encoder1: Could not get/set settings from/on resource.
Debug info: gstv4l2object.c(3501): gst_v4l2_object_set_format_full (): /GstPipeline:pipeline/GstBin:processing_bin_0/GstBin:sink_bin/GstBin:sink_sub_bin1/nvv4l2h264enc:sink_sub_bin_encoder1:
Device is in streaming mode
ERROR from sink_sub_bin_encoder1: Could not get/set settings from/on resource.
Debug info: gstv4l2object.c(3501): gst_v4l2_object_set_format_full (): /GstPipeline:pipeline/GstBin:processing_bin_0/GstBin:sink_bin/GstBin:sink_sub_bin1/nvv4l2h264enc:sink_sub_bin_encoder1:
Device is in streaming mode
ERROR from sink_sub_bin_encoder1: Could not get/set settings from/on resource.
Debug info: gstv4l2object.c(3501): gst_v4l2_object_set_format_full (): /GstPipeline:pipeline/GstBin:processing_bin_0/GstBin:sink_bin/GstBin:sink_sub_bin1/nvv4l2h264enc:sink_sub_bin_encoder1:
Device is in streaming mode
ERROR from sink_sub_bin_encoder1: Could not get/set settings from/on resource.
Debug info: gstv4l2object.c(3501): gst_v4l2_object_set_format_full (): /GstPipeline:pipeline/GstBin:processing_bin_0/GstBin:sink_bin/GstBin:sink_sub_bin1/nvv4l2h264enc:sink_sub_bin_encoder1:
Device is in streaming mode
Quitting

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Hardware Platform (Jetson / GPU):GPU
• DeepStream Version:6.0
• TensorRT Version :8.0.1
• NVIDIA GPU Driver Version (valid for GPU only):470.63.01
• Issue Type( questions, new requirements, bugs):questions,bugs
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing):deepstream-app -c deepstream_app_config0.txt
config_infer_primary0.txt
[property]
gpu-id=0
#net-scale-factor=0.0039215697906911373
net-scale-factor=1.0

0:RGB 1:BGR

model-color-format=1
model-engine-file=s.trt

labelfile-path=labels.txt
num-detected-classes=10
batch-size=1
interval=0
gie-unique-id=1
process-mode=1

0=Detector, 1=Classifier, 2=Segmentation, 100=Other

network-type=0

0:Group Rectange 1:DBSCAN 2:NMS 3:DBSCAN+NMS 4:None

cluster-mode=4
maintain-aspect-ratio=1

parse-bbox-func-name=NvDsInferParseCustomYolox
custom-lib-path=nvdsinfer_custom_impl_yolox1/libnvdsinfer_custom_impl_yolox.so

[class-attrs-all]
nms-iou-threshold=0.45
pre-cluster-threshold=0.25

************************************************************************************************************deepstream_app_config0.txt

[application]
enable-perf-measurement=1
perf-measurement-interval-sec=1

[tiled-display]
enable=0
rows=1
columns=1
width=1024
height=640
gpu-id=0
nvbuf-memory-type=0

[source0]
enable=1

1:camera(v4l2) 2: single uri 3:multi uri 4:rtsp 5 camera(CSI) only for Jetson

type=2
#uri=rtsp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mov
#uri=file:/opt/nvidia/deepstream/deepstream-6.0/sources/objectDetector_Yolo/3.mp4
#uri=file:/home/liu/disk/home/deepstream/deepstream-6.0/sources/objectDetector_Yolo/3.mp4
#/home/liu/disk/VisDrone/VisDrone2019-DET-val/images_erase_ignore_erase_others/0000026_01000_d_0000026.jpg
#/home/liu/disk/home/deepstream/deepstream-6.0/sources/objectDetector_Yolo/2.mp4
uri=file:/home/liu/disk/home/deepstream/deepstream-6.0/samples/streams/sample_1080p_h264.mp4
num-sources=1
gpu-id=0
cudadec-memtype=0
select-rtp-protocol=4

[sink0]
enable=1

3:save file 4:rtsp

type=3
sync=0
source-id=0
gpu-id=0
container=1
codec=1
output-file=./output.mp4
nvbuf-memory-type=0
rtsp-port=8554
udp-port=5400

[tracker]
enable=0

For the case of NvDCF tracker, tracker-width and tracker-height must be a multiple of 32, respectively

tracker-width=640
tracker-height=384
ll-lib-file=/opt/nvidia/deepstream/deepstream-6.0/lib/libnvds_mot_klt.so
gpu-id=0
#enable-batch-process and enable-past-frame applicable to DCF only
enable-batch-process=0
enable-past-frame=0
display-tracking-id=1

[osd]
enable=1
gpu-id=0
border-width=1
text-size=15
text-color=1;1;1;1;
text-bg-color=0.3;0.3;0.3;1
font=Serif
show-clock=0
clock-x-offset=5
clock-y-offset=5
clock-text-size=12
clock-color=0;0;1;1
nvbuf-memory-type=0

[streammux]
gpu-id=0
live-source=0
batch-size=1
batched-push-timeout=40000
width=1024
height=640
enable-padding=1
nvbuf-memory-type=0

[primary-gie]
enable=1
gpu-id=0
gie-unique-id=1
nvbuf-memory-type=0
config-file=config_infer_primary0.txt

[tests]
file-loop=0
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Besides, I run the command line in a docker, where causes the bug while I run it on the local system ,it is no bug and run well.

Seems your video codec driver is not correct. Please reinstall your device driver. Quickstart Guide — DeepStream 6.0.1 Release documentation

But the deepstream-test1-app run well

If you are using the docker. Please make sure you run the docker with correct command.

You may refer to could not select device driver “” with capabilities: [[gpu]]. - NGC GPU Cloud / Docker and NVIDIA Docker - NVIDIA Developer Forums

https://docs.nvidia.com/metropolis/deepstream/dev-guide/text/DS_docker_containers.html#a-docker-container-for-dgpu

Before quiting, it seems that something runs for a while as shown:
Quitting
num of boxes before nms: 70
num of boxes: 10
ERROR from sink_sub_bin_encoder1: Could not get/set settings from/on resource.
Debug info: gstv4l2object.c(3501): gst_v4l2_object_set_format_full (): /GstPipeline:pipeline/GstBin:processing_bin_0/GstBin:sink_bin/GstBin:sink_sub_bin1/nvv4l2h264enc:sink_sub_bin_encoder1:
Device is in streaming mode
ERROR from sink_sub_bin_encoder1: Could not get/set settings from/on resource.
Debug info: gstv4l2object.c(3501): gst_v4l2_object_set_format_full (): /GstPipeline:pipeline/GstBin:processing_bin_0/GstBin:sink_bin/GstBin:sink_sub_bin1/nvv4l2h264enc:sink_sub_bin_encoder1:
Device is in streaming mode
ERROR from sink_sub_bin_encoder1: Could not get/set settings from/on resource.
Debug info: gstv4l2object.c(3501): gst_v4l2_object_set_format_full (): /GstPipeline:pipeline/GstBin:processing_bin_0/GstBin:sink_bin/GstBin:sink_sub_bin1/nvv4l2h264enc:sink_sub_bin_encoder1:
Device is in streaming mode
num of boxes before nms: 70
num of boxes: 10
num of boxes before nms: 70
num of boxes: 11
num of boxes before nms: 58
num of boxes: 8
num of boxes before nms: 64
num of boxes: 9
App run failed

The HW encoder failed. The driver is not correct. What is your GPU? Is it in the list Video Encode and Decode GPU Support Matrix [NEW] | NVIDIA Developer?

Thank all of you, the docker seems lack of video driver libraries (libnvidia-encode.so/libnvcuvid.so), I will try to add them to my docker.

Yes, it is Titan X

However, after adding these libs to docker, it still has the same bug. So how could I add the two libs to the docker.

If you are using the docker. Please make sure you run the docker with correct command.

You may refer to could not select device driver “” with capabilities: [[gpu]]. - NGC GPU Cloud / Docker and NVIDIA Docker - NVIDIA Developer Forums

Yes, in the docker, the nvcc -V and nvidia-smi both can go well.

Can you check whether there is video codec exist in the docker? If they are there, you can try the following command to enable the codec.

ln -s /usr/lib/x86_64-linux-gnu/libnvcuvid.so.1 /usr/lib/x86_64-linux-gnu/libnvcuvid.so
ln -s /usr/lib/x86_64-linux-gnu/libnvidia-encode.so.1 /usr/lib/x86_64-linux-gnu/libnvidia-encode.so

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.