Dell Inspiron 5593 + NVIDIA MX230, driver 450.66, ubuntu 18.05.5 LTS, kernel 5.4.0-47-generic does not swich on NVIDIA

It is likely that the default configuration is using hybrid mode, which would require you to put an environment variable to use nvidia to render. Some more information on your side is needed.

thank you. what info? we tried prime; it says that it is already switched to nvidia. we just bought it and we’d like to test that nvidia works. as i understand we can either use hybrid mode (where Intel is always displayed) or not. once in nonhybrid mode, we can assign either Intel or Nvidia and it will be visible in Ubuntu Details. how we can control the mentioned modes?

on Ubuntu it should be possible to use the nvidia-settings program to control this (a Ubuntu patch to that program). But in any case you would want to provide the output of: “xrandr --listproviders”. Perhaps also the contents of /var/log/Xorg.0.log to show the actual state of your session. But on your screenshot it appears that the system runs in hybrid mode.

ta@ta-Inspiron-5593:~ xrandr --listproviders Providers: number : 0 ta@ta-Inspiron-5593:~ cat /var/log/Xorg.0.log
[ 2.464] (–) Log file renamed from “/var/log/Xorg.pid-910.log” to “/var/log/Xorg.0.log”
[ 2.465]
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[ 2.465] Build Operating System: Linux 4.4.0-148-generic x86_64 Ubuntu
[ 2.465] Current Operating System: Linux ta-Inspiron-5593 5.0.0-23-generic #24~18.04.1-Ubuntu SMP Mon Jul 29 16:12:28 UTC 2019 x86_64
[ 2.465] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.0.0-23-generic root=UUID=4fd72d0f-c757-41a4-8a3f-f178ec81f791 ro quiet splash vt.handoff=1
[ 2.465] Build Date: 02 May 2019 08:06:54AM
[ 2.465] xorg-server-hwe-18.04 2:1.20.4-1ubuntu3~18.04.1 (For technical support please see http://www.ubuntu.com/support)
[ 2.465] Current version of pixman: 0.34.0
[ 2.465] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 2.465] Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 2.465] (==) Log file: “/var/log/Xorg.0.log”, Time: Wed Sep 9 09:45:58 2020

This doesn’t really seem like the full log, in particular the part where it provides the information on detected hardware. Perhaps the log level is reduced from normal. But xrandr --listproviders doesn’t actually name any providers. This could be an issue with the configuration file (the Xorg version 1.20.4 is not too old), but could also just be that it is in single device mode.