Dell Precision 7530 NVIDIA driver trouble

Hello NVIDIA world.

I’ve just installed Fedora 30 on a Dell Precision 7530 laptop. It seems to have two graphic chips… one embedded in the cpu and a quadro.

[root@ncidellprec ~]# lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Device 3e94
01:00.0 VGA compatible controller: NVIDIA Corporation GP104GLM [Quadro P3200 Mobile] (rev a1)

I was able to install the nvidia driver and it seems like the nvidia driver is loaded

root@ncidellprec ~]# lsmod | grep -i nvidia
nvidia_drm             53248  0
nvidia_modeset       1114112  1 nvidia_drm
nvidia              18812928  21 nvidia_modeset
ipmi_msghandler        73728  2 ipmi_devintf,nvidia
drm_kms_helper        212992  2 nvidia_drm,i915
drm                   491520  4 drm_kms_helper,nvidia_drm,i915

but when I try and run the nvidia-settings program, I get the following

ERROR: Unable to load info from any available system

I’ve uploaded the debug report file.

any thoughts?
nvidia-bug-report.log.gz (1.05 MB)

the reason I’m posting this error, is that I believe it related to other errors. For example, there is a gnome shell extension which plots the GPU usage. It doesn’t work. Another gnome shell extension shows the current temperature of the GPU, it also does not work. so there is some basic problem in accessing the GPU on the Dell Precision 7530.

thanks.

It’s an Optimus notebook, the internal display is connected to the intel gpu but you’re using the ‘nomodeset’ kernel parameter which kills the igpu so nothing works. Please remove that parameter, then configure the notebook to use prime:
https://github.com/wildtruc/nvidia-prime-select

manual config:https://devtalk.nvidia.com/default/topic/1022670/linux/official-driver-384-59-with-geforce-1050m-doesn-t-work-on-opensuse-tumbleweed-kde/post/5203910/#5203910

Hi Generix,

I installed nvdia-prime-select and issued the command

sudo nvidia-prime-select nvidia

It all went fine. A message said I needed to logout for the change to take effect, so I rebooted instead.

On reboot, the gdm login display failed to show up.

attached is the bug report log file.
nvidia-bug-report.log.gz (1.12 MB)

It looks like the nvidia-prime script didn’t have any effect, also seems to be quite outdated. So let’s push it it a bit. Please create /etc/X11/xorg.conf.d/11-nvidia-prime.conf with contents

Section "OutputClass"
    Identifier     "nvidia"
    MatchDriver    "nvidia-drm"
    Driver         "nvidia"
    Option         "PrimaryGPU" "Yes"
    Option         "AllowEmptyInitialConfiguration" "true"
EndSection

and create two files optimus.desktop in /etc/xdg/autostart/ and /usr/share/gdm/greeter/autostart/ containing

[Desktop Entry]
Type=Application
Name=Optimus
Exec=sh -c "xrandr --setprovideroutputsource modesetting NVIDIA-0; xrandr --auto"
NoDisplay=true
X-GNOME-Autostart-Phase=DisplayServer

I did as you suggested.

[root@ncidellprec ~]# cat /etc/X11/xorg.conf.d/11-nvidia-prime.conf 
Section "OutputClass"
    Identifier     "nvidia"
    MatchDriver    "nvidia-drm"
    Driver         "nvidia"
    Option         "PrimaryGPU" "Yes"
    Option         "AllowEmptyInitialConfiguration" "true"
EndSection

[root@ncidellprec ~]# cat /etc/xdg/autostart/optimus.desktop
[Desktop Entry]
Type=Application
Name=Optimus
Exec=sh -c "xrandr --setprovideroutputsource modesetting NVIDIA-0; xrandr --auto"
NoDisplay=true
X-GNOME-Autostart-Phase=DisplayServer

[root@ncidellprec ~]# cat /usr/share/gdm/greeter/autostart/optimus.desktop
[Desktop Entry]
Type=Application
Name=Optimus
Exec=sh -c "xrandr --setprovideroutputsource modesetting NVIDIA-0; xrandr --auto"
NoDisplay=true
X-GNOME-Autostart-Phase=DisplayServer

And the bugfile is attached…
nvidia-bug-report.log.gz (1.17 MB)

There is a nice explanation of the optimus laptop configuration at the following link

https://www.dell.com/community/XPS/Hybrid-vs-Optimus-Graphics/td-p/5707715

As it turns out, I can turn off the intel GPU and have the Quadro GPU do all the work in the Bios. The nvidia driver then works fine.

the only bit I don’t like about the laptop is that the CPU’s run rather hot. On my desktop, they are running at 33 deg C while on the laptop it’s closer to 60… I’m wondering if running in dual iGPU and dGPU mode may reduce some of the processing overhead to cool down the PC a bit. But for now I’m good to go.

One bit which does not work is the screen backlight intensity control. I’ll post another topic on that problem later. It’s not so urgent.