Detectron2 for Nvidia Jetson Nano

I’m new and a little inexperienced with Nvidia Jetson.
Can you please help me with my problem I have prepared a Nvidia Jetson with the following instructions:
Afterwards I created a new environment. Now I want to install detectron2 on this environment. Unfortunately all attempts have failed so far. I use Python 3.6.
Unfortunately it already fails with the installation of torchvision. I could still install torch 1.6.
Can someone please give me a step by step guide?
Detectron should run over the GPU.
Thanks a lot!

Can you give more detailed information how you tried the install please?
And what error messages did you see?

First I tried to install it with this instruction:

  1. -> PyTorch Build: Stable (1.6.0) -> Your OS: Linux -> Package: Pip -> Language: Python -> CUDA: 10.2 -> Run this Command: pip3 install torch torchvision

  2. Install Pre-Built Detectron2 (Linux only)
    torch 1.5 -> python -m pip install detectron2 -f \

Error Message: Could not find a version that satisfies the requerement detectron2 (from versions: )
No matching distribution found for detectron2

Second Way:
Install PyTorch via: [python -m pip install detectron2 -f \](python -m pip install detectron2 -f \

This also does not work .
I think there is a compatibility issue between the versions of torch, torchvision and CUDA. How can I find out which versions are compatible and how do I install them correctly on the Jetson Nano?

  1. use pre-built PyTorch from here: PyTorch for Jetson Nano - version 1.6.0 now available
    Make sure to use version that matches your JetPack version

  2. the Detectron2 wheels from the site you have linked will not work as they are for x86 architecture while Jetson series is aarch64 architecture. You must build Detectron from source.

Thank your for this instruction.
How can I find out the JetPack version?
I tried to do it with this Instruction. It seems like torch runs, but I can’t install torchvision.
‘sudo python install’ -> File “”, line 13, in
import torch
ModuleNotFoundError: No module ‘torch’


Please run the following command on your device.

$ cat /usr/include/aarch64-linux-gnu/NvInferVersion.h

For JetPack4.4, the TensorRT version should be 7.1.3.
If you are not using the latest software, it’s recommended to upgrade the device first.

Suppose there is no available detectron prebuilt for ARM.
So you will need to build it from source.

The detail instructions can be found here:


1 Like

I have already solved the problem. Thanks for your support!


When the above requirements are satisfied
To install detectron2 on jetson, just one line?

Thank you.