/dev/nvhost-msenc failed during initialization

tmp.txt (5.7 KB)

• Hardware Platform (dGPU: T4)
• DeepStream Version: 5.1
• TensorRT Version: 7.2.3.4
• NVIDIA GPU Driver Version: 460.91.03
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

When running deepstream app with config file “source4_1080p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt” (attached), with the egl sink disabled and file sink enabled, we ran into this error:

ERROR from sink_sub_bin_encoder1: Device ‘/dev/nvhost-msenc’ failed during initialization
Debug info: gstv4l2object.c(4074): gst_v4l2_object_set_format_full (): /GstPipeline:pipeline/GstBin:processing_bin_0/GstBin:sink_bin/GstBin:sink_sub_bin1/nvv4l2h264enc:sink_sub_bin_encoder1:
Call to S_FMT failed for YM12 @ 1280x720: Unknown error -1

We’ve checked that /dev/nvhost-msenc does not exist in the system

Do you have any ideas to solve this this issue?

Thanks,
Hao

Did you run within docker or run directly on the system?

I ran it directly

The issue has been solved. I reinstalled the nvidia driver and CUDA. Feel free to close this post. Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.