Device '/dev/nvidia0' failed during initialization

Please provide complete information as applicable to your setup.

**• Hardware Platform : dGPU NVIDIA A2000 6GB
**• DeepStream Version: 6.2
**• TensorRT Version 8.5
**• NVIDIA GPU Driver Version (valid for GPU only): 525.85.12

Whenever i use deepstream’s hardware accelerated plugins i receive this error :

Error: gst-resource-error-quark: Device ‘/dev/nvidia0’ failed during initialization (1): gstv4l2object.c(4134): gst_v4l2_object_set_format_full (): /GstPipeline:pipeline0/nvv4l2decoder:nvv4l2-decoder:
Call to S_FMT failed for H264 @ 2560x1080: Unknown error -1
nvstreammux: Successfully handled EOS for source_id=0

I reinstalled whole deepstream, cuda, gstreamer and tensorrt , restarted the computer but its still showing. Please help.

Thank You.

How do you use it? Which app are you using? What is the command line? Do you run the app in docker or directly in your host?

At first i always try on terminal. When i try to run this pipeline on host:

gst-launch-1.0 filesrc location= /home/ali-desktop/Desktop/videolar/funeral.mp4 ! qtdemux ! h264parse ! nvv4l2decoder ! nvvideoconvert ! glimagesink

my full output is this :
Setting pipeline to PAUSED …
Pipeline is PREROLLING …
Got context from element ‘sink’:,“(GstGLDisplayX11)\ gldisplayx11-0”;
ERROR: from element /GstPipeline:pipeline0/nvv4l2decoder:nvv4l2decoder0: Device ‘/dev/nvidia0’ failed during initialization
Additional debug info:
gstv4l2object.c(4134): gst_v4l2_object_set_format_full (): /GstPipeline:pipeline0/nvv4l2decoder:nvv4l2decoder0:
Call to S_FMT failed for H264 @ 2560x1080: Unknown error -1
ERROR: pipeline doesn’t want to preroll.
Setting pipeline to NULL …

** (gst-launch-1.0:29638): CRITICAL **: 14:04:28.864: gst_gl_display_add_context: assertion ‘GST_IS_GL_DISPLAY (display)’ failed

** (gst-launch-1.0:29638): CRITICAL **: 14:04:28.865: gst_gl_display_get_gl_context_for_thread: assertion ‘GST_IS_GL_DISPLAY (display)’ failed

** (gst-launch-1.0:29638): CRITICAL **: 14:04:28.865: gst_gl_display_create_context: assertion ‘display != NULL’ failed
Spinning. Please run ‘gdb gst-launch-1.0 29638’ to continue debugging, Ctrl-C to quit, or Ctrl-\ to dump core.

Why do you use the GStreamer open source plugin “glimagesink”? We never use it in DeepStream samples. Please check the /opt/nvidia/deepstream/deepstream/ in your device or our document Gst-nvvideotestsrc — DeepStream 6.3 Release documentation

But it is not the problem. When i use nveglglessink or nveglglessink -e it is the same error.

Seems the driver is not installed correctly. Can you see “/dev/nvidia0” in your host? Please reinstall the driver.

I reinstalled 3 times but i will do it again. By the way, which latest version of gstreamer does deepstream support?

GStreamer 1.16.2 from the distribution of Ubuntu20.04.

1 Like

I face the same issue as him.

my device is:
Driver Version: 525.85.05

Do we have any solution for this?

Hi @ali.bulus
Is the issue solved? Please let us know if this topic can be closed or not.

Hi @trild-vietnam ,
As Fiona mentioend above, it seems the driver is not well installed. Please file a new topic in case the issue on your side still exist, thank you.

I reinstalled driver but result is the same. I am not using that computer right now. Issue did not solved, i will look it later. Thank you.

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.