Disruption of service when running the Setup script that fetches dependencies


I am trying to build rtx-dlss-4.27 from source
( it’s located at: https://github.com/NvRTX/UnrealEngine/tree/rtx-dlss-4.27)

problem happens when I run Setup.bat, I get this error:

Failed to download ‘http://cdn.unrealengine.com/dependencies/UnrealEngine-16624087/135d2dfcfa4bbe7dd725f03f844323624525ed4a’: The remote server returned an error: (403) Forbidden.

After searching for solution i found this:

–Anyone downloading fresh copies of Unreal Engine code from GitHub will experience a disruption of service when running the Setup script that fetches dependencies, indicated by a “Failed to download” error message. Those with existing copies may receive an error when data is unable to refresh.–

To remedy the error in the builds, a new Commit.gitdeps.xml file has been attached to each release version as an asset. Please replace the existing Engine/Build/Commit.gitdeps.xml file with the new asset.

My question is what should I do, where can i find “Commit.gitdeps.xml”
for rtx-dlss-4.27, or is it the same as for official epics 4.27, or is there any other solution?

Could you give me a hand, please, I need your support

solved, copy paste from :

i hope it will work properly

1 Like

Hi there @andrejkoblar and welcome to the NVIDIA devloper forums.

This should indeed be the fix, the same as for newer branches of NvRTX, see also the discussion regarding building the Caustics branch.