Unable to compile the UE5.1 Caustics branch

Spent the entire weekend trying to get a working build of the UE5.1 Caustics branch.
I solved the first issue with Setup.bat and posted the answer here

I also followed the setup steps for Visual Studio (2022 Community) exactly as described in the documentation here

These are just the last few lines of my Output window.

8>[5682/5683] WriteMetadata UnrealEditor.version cancelled
8>[5683/5683] WriteMetadata UnrealEditor.target cancelled
8>C:\Program Files\Microsoft Visual Studio\2022\Community\MSBuild\Microsoft\VC\v170\Microsoft.MakeFile.Targets(44,5): error MSB3073: The command “…..\Build\BatchFiles\Build.bat -Target=“UnrealEditor Win64 Development” -Target=“ShaderCompileWorker Win64 Development -Quiet” -WaitMutex -FromMsBuild” exited with code 6.
8>Done building project “UE5.vcxproj” – FAILED.
========== Build: 7 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========
========== Build started at 11:14 AM and took 01:52:48.300 hours ==========

When trying to launch any of the Sample projects get a Fatal error popup stating
"Unable to read module manifest from…UnrealEditor.modules’

I even tried a 3rd time uninstalling VS 2022 and using VS 2019 instead.
Mostly worked with 2 caveats.
The Setup.bat issue mentioned above and also needed a more recent dotnet SDK.

After compiling seached Output for errors and came up with
1>Module.D3D12RHI.4_of_4.cpp.obj : error LNK2019: unresolved external symbol NvAPI_D3D12_GetRaytracingCaps referenced in function “public: virtual void __cdecl FD3D12DynamicRHI::Init(void)” (?Init@FD3D12DynamicRHI@@UEAAXXZ)
1>…\Binaries\Win64\UnrealEditor-D3D12RHI.dll : fatal error LNK1120: 1 unresolved externals

I think perhaps the issue may be that the Commit.gitdeps.xml file for the caustics branch needs updating.

Hi there @bach44,

I think this was your last post, so I try and answer here.

I think that most of your troubles come from an issue that EPIC discovered early in May. You guessed correctly that this is connected to the commit.gitdeps.xml file.

There were commits to our RTX 5.1 branch (should be b8dac71f and 66b8968c) to address this. But they might not have made it to the 5.1 Caustics branch.

It might be best for you to try first with the plain NvRTX top of tree and see if you get that to compile and work properly, and then try with the Caustics branch.

Hope that helps!

Thanks Markus
Did as recommended. Plain NvRTX tree compiles without issue.
Compiling NvRTX Caustics branch compiles with errors. Of course I also first copied the Commit.deps.xml file from the NvRTX main branch.
This is the fourth time.
I did notice when downloading the .zip for caustics Bitdefender notices and blocks the following
\UnrealEngine-NvRTX_Caustics-5.1.zip tried to load a malicious resource detected as Amsi.Edge.22.F9CBBDCD and was blocked. Your device is safe.

Guessing Bitdefender is being over zealous? But not sure if something was blocked that would cause a compile issue.

1>[5682/5683] WriteMetadata UnrealEditor.version cancelled
1>[5683/5683] WriteMetadata UnrealEditor.target cancelled
1>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Microsoft\VC\v160\Microsoft.MakeFile.Targets(45,5): error MSB3073: The command “…..\Build\BatchFiles\Build.bat -Target=“UnrealEditor Win64 Development” -Target=“ShaderCompileWorker Win64 Development -Quiet” -WaitMutex -FromMsBuild” exited with code 6.
1>Done building project “UE5.vcxproj” – FAILED.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

One error noticed when compiling was a link error relating to OpenColorIO.
These are the last few lines of my compile. Would it be possible to confirm the latest caustics branch compiles without error?
Not sure why the main NvRTX branch compiles fine but caustics doesn’t.

I reached out to one of the github contributors, let’s see if I can get some feedback. I am not set up myself to compile this, so I need to ask for some help first.

I am told that the mainline RTX branch has been merged to the Caustics branch, so compilation should now work properly.

Thanks Markus.
Compiled and working.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.