NvRTX Branch dependency error

Hey guys,

I’m trying to build the 5.1 branch of NvRTX but running setup.bat I end up here :

I tried using the zip download as well as cloning the repo via GitHub desktop and both led me here. Any info on how to solve this would be greatly appreciated.



Hi @jeffy, welcome to the NVIDIA developer forums!

This might have been caused by issues on the Epic servers for Unreal, check out this post:

It is not clear to me if this needs some action on our part or if everything should work again as expected after a fresh pull.

But they also describe in that post how to work around the issue.

I hope this helps!

Hi @MarkusHoHo ! And thank you!

Yes Homam passed me that link today and I checked it out. And that actually worked. Although it says about some nvapi being changed and if I wanted to overwrite it or something of that sort. I went ahead with “yes” and the setup.bat ran fine.

I went ahead and tried to build the engine but the build failed though :(

Not sure why exactly.

1 Like

Good to hear that you could progress a bit at least.

But that specific error doesn’t ring a bell with me either. If you find a solution before someone here answers, please share here for future reference!

Hi Markus

I took the latest from the branch and it all went well.

Except for the build where after 7 hours I get this

UPDATE: Ok so I just deleted the Datasmith plugins as I wouldn’t be needing them anyways and the build worked and I can open the sample projects and everything now. But for those who would need it I’m not sure of a solution.

For the MSB3073 Error follow this - Just delete directory “Engine\Intermediate\Build\Win64\UE4Editor\Development\VisualStudioDTE” and rebuild from VS. It build successfully.

Once you build with VS, it wont build the entire solution so rebuild it again and everything should work ^^.

1 Like