Does Tesla K40 and ATI Radeon work together

Hi! Till yesterday I was using Geforce GTX 970 GPU on my Ubuntu 14.04 with CUDA 7 installed.

However today NVDIA’s Tesla K40 GPU donation has arrived.
And I gave away my old Geforce 970.
And instead housed “VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Oland XT [Radeon HD 8670 / R5 340X / R7 250/350X]” GPU as my video output. And Tesla K40 for computing.

Now If I boot ubuntu with both Tesla K40 and video output GPU on board then monitor doesn’t display anything.

If I remove Teska K40 and boot then it is perfectly booting.

I want to use Tesla K40 but I also need different GPU for my display.
How can I solve this issue?

Thanks in advance!

If you only had a GTX 970 in your previous setup, then your X display was using the NVIDIA GPU.

If you didn’t change anything in that respect, but simply removed that card and put in another NVIDIA GPU and an ATI GPU, the display may still attempt to use the K40c (I hope it is a K40c, not K40m), which is not what you want.

You need to set up your xorg.conf file to use the AMD/ATI card and not have any reference to NVIDIA. The specifics of this will vary depending on your specific ubuntu distro, as well as whether you intend to install a specific driver for the ATI card or use one that comes with your distro. I’m not sure I can walk you through this in a simple fashion. You may want to google for help with some of those terms as your search terms, e.g. “setup ATI xorg.conf” It may be sufficient just to remove any specific nvidia references from your xorg.conf.

Thanks a lot txbob that solved my issue.

First of all I am sorry txbob. When I thought it worked in reality it wasn’t. It was just ubuntu 14.04 who is now booting. Later I figured out it was booting after I deleted nvidia drivers. Since then I am still trying to get it work without no success. I don’t even remember which steps did take. Below I will describe what I did today.

1.Generated xorg.conf.new file by X configure
in order to see current detected devices. When I generated I got the errors saying
a. drm report modesetting isn;t supported
b. Number of detected devices doesn’t match number of created screens.
However I still got the xorg.conf.new file therefore ignored errors.

  1. Installed Cuda toolkit by these commands

sudo dpkg -i cuda-repo-ubuntu1404_7.0-28_amd64.deb sudo apt-get update
$ sudo apt-get install cuda

which I got from http://www.r-tutor.com/gpu-computing/cuda-installation/cuda7.0-ubuntu url

  1. I made my own xorg.conf file in the /ect/X11 directory by referrring to generated xorg.conf.new file and https://devtalk.nvidia.com/default/topic/821158/setting-up-a-machine-with-a-tesla-k40-with-ubuntu-14-04-and-an-intel-on-board-graphics-card-solved-/ post (I had to change intel to radeon)

  2. When I boot up there were only purple window.

5.After taking out Tesla K40 it booted up nicely. When I checked my xorg.conf file it’s name was changed to xorg.conf.06252015.

  1. I removed /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so* file after reading a post on http://streamcomputing.eu/blog/2011-10-12/both-nvidia-gtx-and-amd-radeon-on-linux/ link(I didn’t follow other steps except removing libglx.so).

  2. After booting I am welcomed by black screen. Even CTRL-ALT-F1 is not working.

I know giving guide would be to much detail but please at least give some hint.

The correct guide to use is this one:

http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-linux/index.html#abstract

Here’s what I would recommend:

  1. Remove the NVIDIA K40 from the system.

  2. start over with a clean install of ubuntu 14.04 (if this is not possible - clean your system as described in the getting started guide linked above http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-linux/index.html#handle-uninstallation)

  3. Get the system and display working the way you want (except CUDA, obviously), using the Radeon card. If you can’t get past this step, your issues have nothing to do with NVIDIA, and I can’t help you in configuring the display to work on a radeon card.

  4. Remove the nouveau driver as indicated in the getting started guide I linked above (http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-linux/index.html#runfile-nouveau)

  5. Power down the system, and put the K40 in.

  6. Power back up. Regarding the display, nothing should have changed.

  7. Get the latest driver runfile installer for the K40c (NOT the CUDA toolkit. The driver. Like 346.59: http://www.nvidia.com/download/driverResults.aspx/84194/en-us).

  8. Run the NVIDIA driver runfile installer. (IMPORTANT: At the end of driver installation, when the driver runfile installer asks if you want to modify the xorg.conf file, select NO.) Make sure it completes successfully. Test by running nvidia-smi as root.

  9. Get the CUDA 7 runfile installer (https://developer.nvidia.com/cuda-downloads). When prompted, de-select the option to install the driver, but install the CUDA toolkit and samples.

  10. Follow post install instructions regarding setting of PATH and LD_LIBRARY_PATH. On Ubuntu, you may need to configure ld directly (ldconfig) instead of using LD_LIBRARY_PATH

  11. Build the samples by issuing make -k in the samples top directory. Test run a sample like deviceQuery.

Notice I’m not suggesting the deb/package manager/repo methods above. If you want to use those, you’re welcome to, and they should work, but they do require a properly cleaned system.

I managed to setup with slight modification of above instructions.

While installing NVIDIA drivers nvidia-libgl(or nvidia-gl) overwrites mesa-libgl. This results AMD GPU based GUI to broke. In order to prevent this I installed nvidia with --no-opengl-files option.

  1. sudo ./NVIDI* --no-opengl-files

However later when installing cuda I couldn’t install CUDA samples. Because It could not find libGLU.so and libGL.so.

Installing libglu1-mesa
Making symbolic link.
Reinstalling nvidia drivers

didn’t solve the issue.

I just ignored installing CUDA samples since I successfully run Caffe examples on GPU which required CUDA.