DPU didn't start after reboot Host

Hi,
I have installed DOCA on a new DPU successfully according to Install DOCA SDK with SDK Manager :: NVIDIA SDK Manager Documentation
And I successfully connected to the DPU by through excuting
sudo ssh ubuntu@192.168.100.2
After that I reboot the Host,but the DPU doesn’t seem to start.
The interface tmfifo_net0 also misses when excuting ‘ifconfig’
How to boot DPU on host?

Hi @2196651959 ,

I suggest the following:

  1. Is tmfifo_net0 missing or is it down? (check with ‘ifconfig -a’). If down, please bring it up.
  2. Check if ‘systemd-udevd’ service is running.
  3. Try to unload the tmfifo module and load it again.
  4. Check for udev messages in /var/log/messages.

Regards,
Chen

Hi,
Thanks for your reply
According to your suggestion,I find:
1.when I excute ifconfig -a,tmfifo_net0 is lost.
2.systemd-udevd is runing.resluts as follow
root@gpu3:/home/why# systemctl status systemd-udevd
● systemd-udevd.service - udev Kernel Device Manager
Loaded: loaded (/lib/systemd/system/systemd-udevd.service; static; vendor preset: enabled)
Active: active (running) since Mon 2023-09-18 16:30:03 CST; 1h 6min ago
TriggeredBy: ● systemd-udevd-kernel.socket
● systemd-udevd-control.socket
Docs: man:systemd-udevd.service(8)
man:udev(7)
Main PID: 689 (systemd-udevd)
Status: “Processing with 48 children at max”
Tasks: 1
Memory: 68.6M
CGroup: /system.slice/systemd-udevd.service
└─689 /lib/systemd/systemd-udevd

Sep 18 16:30:04 gpu3 systemd-udevd[709]: ethtool: autonegotiation is unset or enabled, the speed and duplex are not writable.
Sep 18 16:30:04 gpu3 systemd-udevd[725]: ens14f0: Process ‘/usr/bin/killall -SIGHUP irqbalance’ failed with exit code 1.
Sep 18 16:30:04 gpu3 systemd-udevd[720]: ens14f1: Process ‘/usr/bin/killall -SIGHUP irqbalance’ failed with exit code 1.
Sep 18 16:30:05 gpu3 systemd-udevd[732]: Using default interface naming scheme ‘v245’.
Sep 18 16:30:05 gpu3 systemd-udevd[732]: ethtool: autonegotiation is unset or enabled, the speed and duplex are not writable.
Sep 18 16:30:05 gpu3 systemd-udevd[732]: ib0: Process ‘/usr/bin/killall -SIGHUP irqbalance’ failed with exit code 1.
Sep 18 16:30:05 gpu3 systemd-udevd[737]: Using default interface naming scheme ‘v245’.
Sep 18 16:30:05 gpu3 systemd-udevd[737]: ethtool: autonegotiation is unset or enabled, the speed and duplex are not writable.
Sep 18 16:30:08 gpu3 systemd-udevd[707]: Using default interface naming scheme ‘v245’.
Sep 18 16:30:08 gpu3 systemd-udevd[707]: ethtool: autonegotiation is unset or enabled, the speed and duplex are not writable.
3.I use ‘sudo mod probe tmfifo’ to load it ,but failed as follow
modprobe: FATAL: Module tmfifo not found in directory /lib/modules/5.4.0-152-generic
4.There seems no file named message in this position.
Best wishes
Yuan

Hi,Chen
This seems to be a driver problem. I uninstalled the old driver, installed the latest version, and the problem was solved.
Thanks for your help.