Driver 180.60 + Tesla, Weird Bug...

Hi.
I have the Tesla D870 connected to a machine with a Vista 64 OS.
Installation of the new driver (180.60 beta / 64bit) goes smoothly.
The strange thing is that now only one of the Tesla C870 inside the D870 is recognized as a cuda device.
The other one is not recognized.
The really strange thing is that GPUZ and other utilities show the two C870s to be really different from each other. Different speeds, different GPU clocks etc.
They appears as different GPUs on XP32bit as well but on the 32 bit system they are both identified as CUDA devices anyhow.

This is a screenshot from deviceQuery from the SDK showing that only one C870 is recognized:

This is a side-by-side screenshot from gpuz showing how different the cards are from each other. Is this relevant to the problem at hand?

This is a screenshot from the NVIDIA control panel System Information showing how one C870 is being recognized a part of D870 and the other one is left out… Strange:

What do I do…?
Is this just a bad side effect of the BETA version drivers, a mere bug, or is this a problem with my Tesla device?

Thank you…

Y.

Unless this problem not present with older drivers, I’d say that you’ve got a hardware problem.

I would just like to make this clear.

On Vista 64: Only one of the C870 is being recognized as a CUDA device.

On XP 32: Two devices are recognized properly.

On both OSs: The two C870 have different properties, as the screenshot shows (this was straight-out-of-the-box issue).

Is this indeed a hardware problem?

This looks like a hardware problem.

This is not the conclusion I reached here:

http://forums.nvidia.com/index.php?showtop…mp;#entry467859

Notice that MisterAnderson42 suffered/suffers from the same Two-C870-Are-Reported-With-Different-Bandwidth issue, from there one may deduce that it is a driver issue. Perhaps not unique to Vista. What’s unique to vista (hence this thread is still alive in this forum as well) is the fact that only one C870 is being recognized as a cuda device (while in WinXP they are both recognized as CUDA devices) This suggests that this is rather a driver issue than a hardware issue, no?.

Y.

Breaking news: I updated my WinXP32 with the latest drivers.
The two C870s appear identical on Windows XP with the new driver 180.60.

All problems now occur only in Vista64.
This is definitely a driver bug now…

Y.

Just confirmed it here–I’ll file a bug report. Thanks for the heads up.

Thank you. I also received a reply from Sumit Gupta confirming that it is really a bug.

The bug, mind you, is two fold:

  1. The two C870 have different bandwidths - This happened in previous drivers and is solved in 2.1 under XP and not under Vista.

  2. Only one C870 is recognized as a CUDA device under vista (again, not a problem under xp32).

These two problems may be related and may not be, I wouldn’t know…

Thank you for your help.

Y.

They’re not related. 177.70.18 also had the fix for the first problem you mention.

So it’s two bugs you have on your hands now…

I’ll be waiting…

But they have already solved the first. And how are you certain that the 2nd is a bug? Have you even checked the release notes to look for known issues? Or read other posts on this forum?

This threads: http://forums.nvidia.com/index.php?s=&…st&p=467120 seems to indicate that

have you tried that?

The problem is that you can’t enable both cards through the PhysX dialog. So yeah, it’s a bug/feature/needs more explanation/unicorn.

First of all, Mr. Anderson, it’s definitely a bug because everything works fine under XP but not under Vista. Both OSs had similar problems and the new driver only fixed the WinXP and not the Vista. So again, this is a bug. and they didn’t “already solved the first”, as you put it.
As for Physx, Very interesting thing here: Under XP Physx is disabled and everything is working fine. Under Vista 64, Physx is enabled for one of the Tesla C870 and when I disable it (for it to have the same settings as the XP machine) then… No C870 are identified at all as CUDA capable. Same thing goes when I enable the Physx for my Geforce 8600GT.

So yes… This is an issue to be fixed.

Thank you…

Y.