Driver 470 Quadro M2200 Laptop Screen Blank


I’ve recently upgraded from driver 465 to 470 because of my distribution (Archlinux). Everything usually works quite well even with beta drivers, but not this time. Note that I don’t mind using a beta driver if it helps getting a stabilized driver to more stable Linux distributions.

Anyway, with this new version the driver doesn’t seem to detect my laptop internal screen anymore. I’m lucky to have an external screen connected which doesn’t have the issue so I can use it to debug.

When I look at the Xorg log, the main change between both drivers is this part:

[ 5.479] (–) NVIDIA(GPU-0):
[ 5.479] (–) NVIDIA(GPU-0): Sharp (DFP-2): connected
[ 5.479] (–) NVIDIA(GPU-0): Sharp (DFP-2): Internal DisplayPort
[ 5.479] (–) NVIDIA(GPU-0): Sharp (DFP-2): 960.0 MHz maximum pixel clock
[ 5.479] (–) NVIDIA(GPU-0):


[ 19.166] (–) NVIDIA(GPU-0):
[ 19.166] (–) NVIDIA(GPU-0): DFP-2: disconnected
[ 19.166] (–) NVIDIA(GPU-0): DFP-2: Internal DisplayPort
[ 19.166] (–) NVIDIA(GPU-0): DFP-2: 960.0 MHz maximum pixel clock
[ 19.166] (–) NVIDIA(GPU-0):

Switching back to driver version 465 makes it work again.

I saw that this new 470 driver had additional PRIME support, which I don’t need because I don’t have an iGPU, but maybe this new driver thinks I’m in this configuration (Optimus) and disables the internal display while I actually need it.

My laptop is a Dell M4800 with the 3200x1800 QHD+ screen (this configuration doesn’t support optimus) and a Quadro M2200 installed.

I there a way (kernel parameters or xorg.conf) to force disabling this behaviour with the new driver or what else can be done about this problem ?

Best Regards

Here are the nvidia-bug-report output files:
nvidia-bug-report.log.gz (465.31) (284.1 KB)
nvidia-bug-report.log.gz (470.61.01) (731.9 KB)


I tried with the new release 470.74 and I still get the same blank screen.
nvidia-bug-report.log.gz (470.74) (289.2 KB)

Switching back to the old 465.31 makes it work, nouveau works as well.

I still have the feeling this is related to PRIME, I tried to change configuration parameters but with no luck.


See as well: Quadro M2000M / driver 470.74 fails with debian kernel 5.14.6 (black screen)