Missing VT output with all current drivers on QHD+/K2100M

Running a Dell Precision M4800 A07 with QHD+ 3200x1800 and Quadro K2100M (GK106GLM).

(To my (and others) dismay, Dell has disabled Optimus support on this specific workstation, but that’s a different story)

With all current NVidia drivers, switching to a VT only renders a black screen ; the VT’s themselves are functional (as witnessed by blind-typing).

Tested with :

  • RHEL 6.5 : Xorg 1.13.0 , NVidia 331.20 (driver officially supported by Dell) ;
  • Fedora 20 : Xorg 1.14.4 , NVidia 331.49
  • Fedora 21 rawhide : Xorg 1.15.0 , NVidia 337.12

nvidia-bug-report.log.gz (221 KB)

Did you observe this issue before installing nvidia driver on laptop? Did init 3 shows VT login ? Also did you test with any other drivers from ftp://download.nvidia.com/XFree86/Linux-x86_64/ ?

Thanks for taking this up, Sandip.

  1. With the nouveau drivers, I have full (high-res) VT, and I am able to switch continuously between X and VT without issues ;

  2. ‘init 3’ gives functional VT login. As soon as X (with nvidia.ko) is loaded, either through startx or telinit 5, the VT’s are rendered black ;

  3. switching to a VT and switching back to X, renders a black screen too. In other words : after a VT has been switched too, X needs to be restarted to regain a visual.

  4. As stated in my original post, I did try with several drivers : 331.20, 331.49, 337.12 ; with different kernel versions.

Would you like me to try anything else ? The lack of Optimus is aggravating, and the missing VT’s are adding insult to injury.


Update 28/04/2014 :

While waiting for Sandip’s reply, I also tested with RHEL 7.0 RC (kernel 3.10.0, Xorg 1.15.0, NVidia 337.12) : VT’s are again functional (able to login, blindtyping), but again there is no visual output whatsoever (black screen).

So this issue is reproducible with all current Fedora/CentOS/Red Hat iterations, with all current kernels, and with all current proprietary NVIDIA drivers.

I have the same computer, Dell Precision M4800 A07 with QHD+ 3200x1800 and Quadro K2100M (GK106GLM), also without Optimus support.

I can confirm that VT does not work (no visible feedback) after starting X11 with NVIDIA driver.

Some other notes. Laptop screen also goes dark after screen saver turns off display, but reappear after switching to any VT and back to X11. nomodeset is required for boot/install. NVIDIA driver does not support any other resolution than native 3200x1800, except scaled modes. If I choose a scaled mode and save xorg.conf, screen is larger than scaled resolution after restart, so I get black border to the right and bottom if I move my cursor to screen edge (not sure if my explanation is accurate, English is not native tongue).

So far tested with Debian Sid (331.67), PC-BSD 10 (not sure), Ubuntu 14.04 (331.38).

I’ve tested with EFI secure boot, both on and off, and tested with BIOS.

And from my conversations with Dell, it is to be concluded there will never be any Optimus for this model, due to the implemented architecture (or design flaw(s), as I’d like to call it).

Indeed. This issue is limited to the internal (eDP) display though, as an externally attached monitor exhibits normal behaviour when returning from screen saver. DPMS issue ?

Witnessing the lack of response from NVIDIA [1], it appears this issue isn’t too high on the priority list.
Specifically to avoid these kinds of dead-ends, I firmly counted on the possibility to fall back to Intel HD4600 IGP (which provides decent open source drivers), which - due to the absence of Optimus : thanks, Dell ! - is not possible on the M4800.

[1] contrary to fast response/resolution in nouveau : https://bugs.freedesktop.org/show_bug.cgi?id=76319

Sorry for the rant : quite simply. I am disappointed in this top-dollar “workstation-class” laptop.

Thank you for the additional information @didierm. In my case, don’t need the extra horse power from the NVIDIA GPU, or the QHD+, but this computer was passed down to me at work, so I have to live with it for now. Unfortunately, I can’t experiment any more with different setups, because I am depended on a working system for my work! At the moment, I am using Ubuntu 14.04. I would suspect NVIDIA and DELL are very aware of these issues, because I believe this model can be ordered preloaded with Ubuntu 12.04. [Edit:] M4800 is also listed on Ubuntu certified page. If you go to DELL driver page, you can actually find a recent driver package and a DELL 12.04 iso image. I did several attempts to install it from USB, but there was a GRUB package that could not be installed. Maybe I would have better luck with a DVD installation. Nomodeset was required to start the installation.

Sadly, with nouveau, I could not detect external displays for some reason. I tried hdmi and trough docking station. Hopefully it’ll work in future Ubuntu releases, that would’ve been great.

filed Bug 1512547 to track this issue.

Sorry for the very unnecessary dump, but thanks for the update sandipt.

Tested with latest stable 331.79 and beta 337.19 : bug still present.

I would like to also request this gets some attention. The way Dell shipped this laptop requires us to use the Nvidia driver card (no IGP) and right now this is very broken. Every time my laptop locks the screen I have to switch between VT until I can get the graphics to return.

I have also been having this problem. I created a post about it on the archlinux forums a little while ago, but never came up with a solution, here is the link to the post for reference:


Please nvidia fix this problem! Thanks.

Check your kernel config file guys. You probably should have efifb enabled + CONFIG_X86_SYSFB=y
I had similar issue, when Xorg worked, but VT’s - doesn’t. Enabling CONFIG_X86_SYSFB=y solved this…
Note: I use ordinary desktop system with UEFI/no-SecureBoot.

p.s. I understand that your problems related to binary-based distros, but I’ve used this manual - [url]http://gentoo-en.vfose.ru/wiki/UEFI#Kernel_Options[/url] and X86_SYSFB option… so… FYI.

Tested with latest NVIDIA proprietary 337.25 driver : bug still present.

Additionally (but not yet reported, IIRC), screen brightness doesn’t function either.

337.25, VT output bug confirmed. Clean install Ubuntu 14.04 64 bit (temporally swapped original hard disk for testing).

Bug still present with binary blob 340.17.

Bug still present with (updated Dell Bios A09 and) NVIDIA blob 340.24.

Bug still present with blob 340.32

Bug still present with blob 343.22.

Bug reported about half a year ago (blob 331.49).
But hey, which Linux user needs VT’s anyway ?

Six months and counting ; I guess there’s no use in any further reporting of current blobs not fixing the issue.

2015 may prove to be an interesting year, with AMD upping the ante (amdgpu announcement, [url]AMD Moves Forward With Unified Linux Driver Strategy, New Kernel Driver - Phoronix).