[Driver & Cuda Installation] Conflict packages in Fedora 34 - 470.63.01-1.fc34

After an update on my Fedora 34, I get these messages from the DNF,

$ sudo dnf update
[sudo] password for juan: 
Last metadata expiration check: 0:11:32 ago on Fri 24 Sep 2021 09:37:15 CEST.
Dependencies resolved.

 Problem 1: package akmod-nvidia-3:470.63.01-1.fc34.x86_64 requires nvidia-kmod-common >= 3:470.63.01, but none of the providers can be installed
  - cannot install the best update candidate for package akmod-nvidia-3:470.57.02-1.fc34.x86_64
  - package xorg-x11-drv-nvidia-3:470.63.01-3.fc34.x86_64 is filtered out by modular filtering
 Problem 2: package kmod-nvidia-3:470.63.01-1.fc34.x86_64 requires akmod-nvidia = 3:470.63.01-1.fc34, but none of the providers can be installed
  - package akmod-nvidia-3:470.63.01-1.fc34.x86_64 requires nvidia-kmod-common >= 3:470.63.01, but none of the providers can be installed
  - cannot install the best update candidate for package kmod-nvidia-3:470.57.02-1.fc34.x86_64
  - package xorg-x11-drv-nvidia-3:470.63.01-3.fc34.x86_64 is filtered out by modular filtering
==============================================================================================================================================================================================================================================
 Package                                              Architecture                                   Version                                                    Repository                                                               Size
==============================================================================================================================================================================================================================================
Skipping packages with broken dependencies:
 akmod-nvidia                                         x86_64                                         3:470.63.01-1.fc34                                         rpmfusion-nonfree-updates                                                27 k
 kmod-nvidia                                          x86_64                                         3:470.63.01-1.fc34                                         rpmfusion-nonfree-nvidia-driver                                          11 k

Transaction Summary
==============================================================================================================================================================================================================================================
Skip  2 Packages

Nothing to do.
Complete!

The nvidia-smi

nvidia-smi 
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

The kernel I am running: Linux fedora 5.14.7-200.fc34.x86_64

I had it working by following the steps explained here: CUDA Toolkit 11.4 Update 2 Downloads | NVIDIA Developer

I think the issue is that the Nvidia driver provided is 470.57.02-1, while it conflicts with some of the dependencies on my system, trying to get 470.63.01-1.fc34.

Is any work around this?

Is it possible to provide a more recent version here? CUDA Toolkit 11.4 Update 2 Downloads | NVIDIA Developer

Any pointers will be appreciated.

Thanks
Juan

1 Like

[Update] I manually installed the driver 470.63.01 and at least now I can use the GPU and run CUDA programs.

Hi, could you describe where you found the newer version of the driver ?
I’ve tried to modify the following url with another version name but without success.

https://developer.download.nvidia.com/compute/cuda/11.4.2/local_installers/cuda-repo-fedora34-11-4-local-11.4.2_470.57.02-1.x86_64.rpm

How did you find the RPM for 470.63.01 ?
Did you need to run other commands ?

Thanks.

I found it here: NVIDIA DRIVERS Linux x64 (AMD64/EM64T) Display Driver

I did the installation as follows:

sudo systemctl set-default multi-user.target

reboot 

Then install the driver:

sudo ./NVIDIA-Linux-x86_64-470.63.01.run

And then I enabled the graphical interface again:

sudo systemctl set-default graphical.target

reboot 

This worked for me.