Driver finds wrong gcc -- [driver does not use the right gcc version]

I downloaded the latest cuda offline installer Attempting to install the driver errors out with the error message

Failed to verify gcc version. See log at /tmp/cuda-installer.log for details.

Content of /tmp/cuda-installer.log are

[INFO]: Setting driver=true
[INFO]: Setting silent=true
[INFO]: Driver not installed.
[INFO]: Checking compiler version...
[INFO]: gcc location: /usr/bin/gcc

[INFO]: gcc version: gcc version 13.0.1 20230314 (experimental) [revision 42630fadbe248717859d61c0244c821c32b4e52c] (SUSE Linux) 

[ERROR]: unsupported compiler version: 13.0.1. Use --override to override this check.

I have gcc-11, gcc-12, and gcc-13 versions installed side-by-side on my system. Based on the docs, both gcc-11 and gcc-12 should be compatible with the driver. gcc points to gcc-13 on my system. I’ve tried setting the typical environment variables that are used by build systems to try to get the installer to use gcc-12 and without exception it always uses the default /usr/bin/gcc which points to gcc-13. I’ve tried setting local aliases and it still picks /usr/bin/gcc. It seems like it explicitly looks for a /usr/bin/gcc regardless of any other types of inputs. I do not want to overwrite a symlink. Is there a way to get the installer to use the right version of gcc? If not, where can I file a bug report on this?