Driver problems with Cuda 6.5, Ubuntu 14.04 x64, GTX 970

Hardware: i5 CPU, GTX 970 GPU, ASRock Z97 Extreme3 motherboard
Software: Ubuntu 14.04 x64, Cuda 6.5, Nvidia driver 343.22
User: Intermediate experience with various versions of Linux

Perceived problem: I cannot seem to get Cuda 6.5 to work properly with my new GTX 970 video card on Ubuntu 14.04 x64. Reboot after Cuda install results in blank screen when Unity should appear. Has anyone had success with Ubuntu 14.04x64, GTX 970/980 and Cuda 6.5?

More Details: Starting with a fresh install of Ubuntu 14.04 x64, I am unable to properly install Cuda 6.5. The install process goes along just fine (i can even make the samples without issue though i cannot run them) but it appears that the install process also installs 340.XX video card drivers which results in a blank screen at reboot. I can get tty1 to appear (CTRL+ALT+F1) but everything seems to indicate that the driver is incompatible and thus the video card is not recognized. And it appears that the only Linux driver compatible with the GTX 970 is 343.22.
I’ve also tried installing video driver 343.22 before and after Cuda 6.5 with similar results. If I install 343.22 after Cuda 6.5 and re-make the Cuda samples, they show an error still referring to missing “nvidia-340-uvm”.
Can I install Cuda 6.5 without the additional video card drivers (340.XX) and keep the working 343.22 drivers? What order should I install video card drivers relative to Cuda 6.5 (if at all)?

To further confuse matters, I was able to install everything with success the very first time. (Ubuntu 14.04x64 -> 343.22 drivers -> Cuda6.5) I went on to irreversibly nuke some environment variable details while working with Neural Network software (Caffe). At the time it seemed like a fresh install (of everything including Ubuntu) would be the easiest fix, but I have been unable to re-install Cuda 6.5 properly since then after numerous attempts.

I can paste command outputs when I go home later today to help debug.

Thanks in advance for the help,
Dan

Are you using the updated CUDA 6.5 packages that were released to support GTX980/970 (i.e. cc5.2) devices specifically?

https://developer.nvidia.com/cuda-downloads-geforce-gtx9xx

And I would suggest using the runfile installer method, not the repo method.

If you were using an older toolkit (even the previous CUDA 6.5 that has the 340.xx drivers that you are struggling with), the correct install technique is to install the proper driver for your GPU first, then run the toolkit runfile installer method (not repo method) and deselect the option to install the driver that is bundled with the runfile installer. Note that this advice is only necessary for previous toolkit versions. You should be able to use the runfile installer for GTX980/970 that I indicated at the top of this post, as-is, including installation of the bundled driver.

I am certain that I used the special package for the GTX970/980 the first time, almost certain that I failed to see the disclaimer on the download page and used the generic x64 linux package on subsequent attempts…That’s what I get for being impatient. Thank you for the reality check.

Any reason why I should avoid the “.deb” packages vs the “.run”? I generally see people recommending the opposite when it comes to nvidia toolkits/drivers but I have never come across a decent explanation/reason.

It’s a personal opinion/preference. Use the .deb if you like. For me, the process of saying “deselect the option to install the driver” is an obvious and easy to follow instruction with the runfile installer, because the installer prompts you with that question. It’s crystal clear. On the other hand with the repo method, I have no idea how to instruct someone to do that. It’s probably just my own lack of experience/knowledge.

I got Cuda up and running. It was simply the fact that I skipped right over the special build of v6.5 for GTX9xx cards and was installing the generic Linux x64 toolkit instead. Thanks again for setting me straight.

are you using cuda .deb pkg or .runfile? i 'm having similar issues . i’m using i5 cpu haswell, asrock oc formula board with 970, 680, 780. there must have been some sort of an ubuntu update , after wed. night i got the black screen of death and i’m going through the pain trying to figure out what’s going on. i’m using ubuntu 14.04. tried cuda 6.5 and 7.0rc . more details here. i can use some help. thank

https://devtalk.nvidia.com/default/topic/814389/cuda-setup-and-installation/z97-mb-cuda-nvidia-driver-ubuntu-14-04-black-screen/