Drivers for GeForce GTX 970 installed but no display output on Ubuntu 22.04

Apparently the driver is installed, however no display output on gpu. What I’ve tried so far:

  • Reinstalled drivers (2x - using sudo apt install nvidia-drivers-550 and ubuntu-drivers autoinstall)
  • Changed options nvidia-drm modeset from 0 to 1 in /etc/modprobe.d/* and /lib/modprobe.d/*, applied with sudo update-initramfs -u
  • sudo prime-select on-demand → reboot → sudo prime-select nvidia → reboot
  • Changed GRUB_CMDLINE_LINUX_DEFAULT= from quiet splash to nomodeset and applied with sudo update-grub
  • Setted two env variables: __GLX_VENDOR_LIBRARY_NAME=nvidia and __NV_PRIME_RENDER_OFFLOAD=1 in /etc/environment
  • Added Option "PrimaryGPU" "true" in /usr/share/X11/xorg.conf.d/10-nvidia.conf
  • Tried changing kernel to use 6.5.0-1020-oem kernel (rollback to 6.5.0-28-generic)

During the tries, I had to enable autologin due to login loop and had blinking screen after reboot - rollback the second and fourth bullet points. Autologin is still enabled. I do not want to change display manager, currently using gdm3.

Any suggestions to solve this?

nvidia-bug-report.log.gz (468.5 KB)

➤ sudo gpu-manager
last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
can't access /opt/amdgpu-pro/bin/amdgpu-pro-px
Looking for nvidia modules in /lib/modules/6.5.0-28-generic/kernel
Looking for nvidia modules in /lib/modules/6.5.0-28-generic/kernel/nvidia-550srv
Looking for nvidia modules in /lib/modules/6.5.0-28-generic/kernel/nvidia-550
Found nvidia.ko module in /lib/modules/6.5.0-28-generic/kernel/nvidia-550/nvidia.ko
Looking for amdgpu modules in /lib/modules/6.5.0-28-generic/kernel
Looking for amdgpu modules in /lib/modules/6.5.0-28-generic/updates/dkms
Is nvidia loaded? yes
Was nvidia unloaded? no
Is nvidia blacklisted? no
Is intel loaded? yes
Is radeon loaded? no
Is radeon blacklisted? no
Is amdgpu loaded? no
Is amdgpu blacklisted? no
Is amdgpu versioned? no
Is amdgpu pro stack? no
Is nouveau loaded? no
Is nouveau blacklisted? yes
Is nvidia kernel module available? yes
Is amdgpu kernel module available? no
Vendor/Device Id: 8086:152
BusID "PCI:0@0:2:0"
Is boot vga? yes
Vendor/Device Id: 10de:13c2
BusID "PCI:1@0:0:0"
Is boot vga? no
Chassis type: "3"
Laptop not detected
Is nvidia runtime pm supported for "0x13c2"? no
Checking power status in /proc/driver/nvidia/gpus/0000:01:00.0/power
Runtime D3 status:          Disabled by default
Is nvidia runtime pm enabled for "0x13c2"? no
Skipping "/dev/dri/card1", driven by "nvidia-drm"
Skipping "/dev/dri/card0", driven by "i915"
Skipping "/dev/dri/card1", driven by "nvidia-drm"
Skipping "/dev/dri/card0", driven by "i915"
Skipping "/dev/dri/card1", driven by "nvidia-drm"
Skipping "/dev/dri/card0", driven by "i915"
Skipping "/dev/dri/card1", driven by "nvidia-drm"
Found "/dev/dri/card0", driven by "i915"
output 0:
Number of connected outputs for /dev/dri/card0: 1
Does it require offloading? yes
last cards number = 2
Has amd? no
Has intel? yes
Has nvidia? yes
How many cards? 2
Has the system changed? No
Takes 0ms to wait for nvidia udev rules completed.
Intel IGP detected
NVIDIA hybrid system
Creating /usr/share/X11/xorg.conf.d/11-nvidia-prime.conf
Setting power control to "on" in /sys/bus/pci/devices/0000:01:00.0/power/control
➤ sudo lshw -C display
       description: VGA compatible controller
       product: GM204 [GeForce GTX 970]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:31 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff
       description: VGA compatible controller
       product: Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       logical name: /dev/fb0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom fb
       configuration: depth=32 driver=i915 latency=0 resolution=1920,1080
       resources: irq:29 memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64) memory:c0000-dffff
➤ nvidia-smi
Thu Apr 25 18:26:18 2024       
| NVIDIA-SMI 550.67                 Driver Version: 550.67         CUDA Version: 12.4     |
| GPU  Name                 Persistence-M | Bus-Id          Disp.A | Volatile Uncorr. ECC |
| Fan  Temp   Perf          Pwr:Usage/Cap |           Memory-Usage | GPU-Util  Compute M. |
|                                         |                        |               MIG M. |
|   0  NVIDIA GeForce GTX 970         Off |   00000000:01:00.0 Off |                  N/A |
| 22%   40C    P8             11W /  151W |     190MiB /   4096MiB |      0%      Default |
|                                         |                        |                  N/A |
| Processes:                                                                              |
|  GPU   GI   CI        PID   Type   Process name                              GPU Memory |
|        ID   ID                                                               Usage      |
|    0   N/A  N/A      2187      G   /usr/bin/gnome-shell                            2MiB |
|    0   N/A  N/A      6008      G   ...erProcess --variations-seed-version         89MiB |
|    0   N/A  N/A      7428      G   ...,262144 --variations-seed-version=1         91MiB |
➤ sudo prime-select query

➤ glxinfo | grep vendor
server glx vendor string: SGI
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation

➤ mokutil --sb-state
This system doesn't support Secure Boot
➤ apt list --installed | grep nvidia

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libnvidia-cfg1-550/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev amd64 [installed,automatic]
libnvidia-common-535/jammy,jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev all [installed]
libnvidia-common-550/jammy,jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev all [installed,automatic]
libnvidia-compute-535/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev i386 [installed]
libnvidia-compute-550/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev amd64 [installed,automatic]
libnvidia-compute-550/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev i386 [installed,automatic]
libnvidia-decode-535/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev i386 [installed]
libnvidia-decode-550/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev amd64 [installed,automatic]
libnvidia-decode-550/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev i386 [installed,automatic]
libnvidia-egl-wayland1/jammy,now 1:1.1.9-1.1 amd64 [installed,automatic]
libnvidia-encode-535/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev i386 [installed]
libnvidia-encode-550/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev amd64 [installed,automatic]
libnvidia-encode-550/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev i386 [installed,automatic]
libnvidia-extra-550/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev amd64 [installed,automatic]
libnvidia-fbc1-535/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev i386 [installed]
libnvidia-fbc1-550/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev amd64 [installed,automatic]
libnvidia-fbc1-550/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev i386 [installed,automatic]
libnvidia-gl-535/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev i386 [installed]
libnvidia-gl-550/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev amd64 [installed,automatic]
libnvidia-gl-550/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev i386 [installed,automatic]
linux-modules-nvidia-550-6.5.0-1020-oem/jammy-updates,jammy-security,now 6.5.0-1020.21+2 amd64 [installed]
linux-modules-nvidia-550-6.5.0-28-generic/jammy-updates,jammy-security,now 6.5.0-28.29~22.04.1+2 amd64 [installed,automatic]
linux-modules-nvidia-550-generic-hwe-22.04/jammy-updates,jammy-security,now 6.5.0-28.29~22.04.1+2 amd64 [installed]
linux-objects-nvidia-550-6.5.0-1020-oem/jammy-updates,jammy-security,now 6.5.0-1020.21+2 amd64 [installed,automatic]
linux-objects-nvidia-550-6.5.0-28-generic/jammy-updates,jammy-security,now 6.5.0-28.29~22.04.1+2 amd64 [installed,automatic]
linux-signatures-nvidia-6.5.0-1020-oem/jammy-updates,jammy-security,now 6.5.0-1020.21+2 amd64 [installed,automatic]
linux-signatures-nvidia-6.5.0-28-generic/jammy-updates,jammy-security,now 6.5.0-28.29~22.04.1+2 amd64 [installed,automatic]
nvidia-compute-utils-550/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev amd64 [installed,automatic]
nvidia-dkms-550/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev amd64 [installed]
nvidia-driver-550/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev amd64 [installed]
nvidia-firmware-550-550.67/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev amd64 [installed,automatic]
nvidia-kernel-common-550/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev amd64 [installed,automatic]
nvidia-kernel-source-550/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev amd64 [installed,automatic]
nvidia-prime/jammy,jammy,now all [installed]
nvidia-settings/jammy,jammy,now 510.47.03-0ubuntu1 amd64 [installed,automatic]
nvidia-utils-550/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev amd64 [installed,automatic]
xserver-xorg-video-nvidia-550/jammy,now 550.67-1pop0~1710948064~22.04~b0f6b1b~dev amd64 [installed,automatic]

There are no monitors detected on the nvidia gpu, did you connect them to the onboard intel igpu instead? Please connect them to the nvidia gpu. If already done so, please check monitor cables.