DS4 deepstream-test4-app based on Xavier

I have installed Jetpack 4.2.1 and DS4 by using sdkmanager and then installed packages like kafka below

sudo apt-get install libglib2.0 libglib2.0-dev sudo apt-get install libjansson4 libjansson-dev
$ sudo apt-get install librdkafka1=0.11.3-1build1

and then installed zoopkeeper and kafka and I checked it was working well and then made new topic e.g dsapp
it was no problme when I did test about this source on DS 3.0

I have found this error below

./deepstream-test4-app  -i /opt/nvidia/deepstream/deepstream-4.0/samples/streams/sample_720p.h264 -p /opt/nvidia/deepstream/deepstream-4.0/lib/libnvds_kafka_proto.so  --conn-str=";1280;dsapp"  -s 1
Using winsys: x11 
ERROR from element nvmsg-broker: Could not configure supporting library.
Error details: /dvs/git/dirty/git-master_linux/deepstream/sdk/src/gst-plugins/gst-nvmsgbroker/gstnvmsgbroker.c(332): gst_nvmsgbroker_start (): /GstPipeline:dstest4-pipeline/GstNvMsgBroker:nvmsg-broker:
unable to connect to broker library
Returned, stopping playback
Deleting pipeline

so now I am checking for gst-nvmsgbroker (332)

$ vi gstnvmsgbroker.c
  self->connHandle = self->nvds_msgapi_connect (self->connStr,
                               (nvds_msgapi_connect_cb_t) nvds_msgapi_connect_callback,
  if (!self->connHandle) {
    if (self->libHandle) {
      dlclose (self->libHandle);
      self->libHandle = NULL;
                       ("<b>unable to connect to broker library</b>"));
    return FALSE;

I am checking others

$ /opt/nvidia/deepstream/deepstream-4.0/lib$ ldd libnvds_kafka_proto.so
	linux-vdso.so.1 (0x0000007fb373e000)
	libjansson.so.4 => /usr/lib/aarch64-linux-gnu/libjansson.so.4 (0x0000007fb36bd000)
	librdkafka.so.1 (0x0000007fb35e3000)
	libglib-2.0.so.0 => /usr/lib/aarch64-linux-gnu/libglib-2.0.so.0 (0x0000007fb34d5000)
	libnvds_logger.so (0x0000007fb34c3000)
	libstdc++.so.6 => /usr/lib/aarch64-linux-gnu/libstdc++.so.6 (0x0000007fb3330000)
	libc.so.6 => /lib/aarch64-linux-gnu/libc.so.6 (0x0000007fb31d7000)
	/lib/ld-linux-aarch64.so.1 (0x0000007fb3713000)
	libpthread.so.0 => /lib/aarch64-linux-gnu/libpthread.so.0 (0x0000007fb31ab000)
	libz.so.1 => /lib/aarch64-linux-gnu/libz.so.1 (0x0000007fb317e000)
	libdl.so.2 => /lib/aarch64-linux-gnu/libdl.so.2 (0x0000007fb3169000)
	libpcre.so.3 => /lib/aarch64-linux-gnu/libpcre.so.3 (0x0000007fb30f7000)
	libm.so.6 => /lib/aarch64-linux-gnu/libm.so.6 (0x0000007fb303d000)
	libgcc_s.so.1 => /lib/aarch64-linux-gnu/libgcc_s.so.1 (0x0000007fb3019000)

/opt/nvidia/deepstream/deepstream-4.0/lib$ nm libnvds_kafka_proto.so 
nm: libnvds_kafka_proto.so: no symbols

I added option “-c cfg_kafka.txt” , it was same

Could you give me advice

Please check if steps in following post helps:

I have already done a test about TEST4 in DS3.0 but it’s no problem
I changed it in DS3.0 below

$ vi deepstream_test4.app.c 
#define PROTOCOL_ADAPTOR_LIB  "/usr/lib/aarch64-linux-gnu/tegra/libnvds_kafka_proto.so"
#define CONNECTION_STRING ";1280;dsapp2"

and then installed both of them like zoopkeeper and kafka
I made a topic like dsapp2 by using kafka and I checked JSON messages from Kafka

I think this function can’t connect to shared library so does it work properly in yours?

So you have verified below CONNECT_STRING working:

#define CONNECTION_STRING ";9092;metromind-start"

But your string does not work:

#define CONNECTION_STRING ";1280;dsapp2" looks to be local streaming. Maybe you can try to set up a real server?

Thanks for your help