sample application 4 in deepstream 4.0

  • I ran Kafka broker on the PC listening to the message sent from a Jetson board with sample application 4. It seems to run, but when I tried to run the sample application 4 from Jetson board it generated an error.
    ERROR from element nvmsg-broker: Could not initialize supporting library.
    Error details: gstnvmsgbroker.c(297): gst_nvmsgbroker_start (): /GstPipeline:dstest4-pipeline/GstNvMsgBroker:nvmsg-broker:
    unable to open shared library
    Returned, stopping playback
    Deleting pipeline

    I did try to clear up the cache several times, but I got the same error each time.

  • I am also confused about how does the communication work between the perception server and analytic server. I think this should be able to set up in the C file in sample application 4 for DeepStream:
    #define CONNECTION_STRING ""
    #define CONFIG_FILE_PATH ""

    I think the CONNECTION_STRING should be formatted as ;;. Do I need to wirte a task file myself? Is the PROTOCOL_ADAPTOR_LIB the location of where “” is? And what does the CONFIG_FILE_PATH referring to?

  • I am facing same problem. How did you solve it?

    Issue resolved by updating Deepstream 4.0 to 4.0.1!!!