dual GTX280M problem Alienware M17x, win7 x64

Hi,

I am having trouble configuring this laptop for CUDA-apps execution (this is not a development machine).

The laptop came with SLI enabled by default, so I first tried to run my CUDA-apps with that configuration.
Both GTX280M show up in deviceQuery, but my app fails randomly (with kernel errors) when running with both GPUs.
It runs well when using only one GPU, regardless which one.

With SLI disabled, the NVIDIA Control Panel still shows 2 GTX280M, but deviceQuery shows only 1 (as every other CUDA-app does).

I tried with CudaToolkit v2.3 and v3.0beta1, and display drivers 195.62 and 195.81 : same results.

Concerning the failure, I doubt that my app is causing problems because it has been running for quite some time on various hardware (desktops with xp32/xp64 using S1070 or (1 to 4)xC1060, and laptops with single GPU running xp32, vista32/64 and win7).


So I have no clue of what is happening, if anyone has any advice?
I think I’ll try to contact Dell/Alienware about that tomorrow, but if anyone has already gone down that path before, I’d be happy to learn more.

Moreover, as the CUDA-apps are able to run on both GPU as long as I use only 1 of them (with SLI enabled) this does not look like a hardware problem, but rather like a driver / configuration / BIOS issue (???)

Note: I tried connecting another screen (some posts mention win7 needs to have a screen connected to a GPU to make it “active” (?)), but it apparently appeared on the same card as the laptop display …
I also tried the registry edit for “DisplayLessPolicy” and “LimitVideoPresentSources” (which were already present for one of the GPU) but that did not change anything.

Any help / advice / solution appreciated :)

Thanks!

*** EDIT ***: I was not using the “Control\Class{4D36E968-E325-11CE-BFC1-08002BE10318}” registry entries (but the Video ones).
That now “works” when disabling SLI (where did I read that SLI settings did no longer matter for drivers >=190.xx ??)
The only remaining problem is that each time I access CUDA (even with deviceQuery) there is a global screen/machine freeze for 5 to 10 seconds … (same for 195.62 and 195.81 drivers).

Edit: I replied to the wrong thread about an irrelevant issue! Ignore me…

ok. Just being ignored: also tried to post in the enflammed 4x GTX295 thread, with no response at all.
Apparently nobody cares, and/or there are no other dual-GTX*M laptops running win7 with similar issues around …

Thanks to evanevery, this might get fixed one day … figure I’ll just wait for the next driver release(s) and cross my fingers …
sorry for the useless posts (how to I delete this thread?)

:sick: