eGPU issue: how to enable the external GPU to recognize the external monitor?

Dear Generix and dear all,

I am struggling to set up the external GPU on my laptop computer (Fujitsu Celsius H760). Installing Ubuntu 18.04 LTS and Nvidia driver version 430.40 ended up letting the laptop computer recognize both the internal and external GPUs based on ‘nvidia-smi’, but I got stuck to enable the external GPU to recognize the external monitor (ASUS Nvidia 3D vision ready). I would very much appreciate it if you kindly help me figure this issue out.

  • OS: Ubuntu 18.04 LTS
  • Nvidia driver ver: 430.40
  • Internal GPU: Nvidia Quadro M1000M
  • External GPU: Nvidia Quadro P4000
  • eGPU case: Razer Core X Chroma
  • The external monitor ASUS is connected to the external GPU Quadro P4000 vid DP cable
  • The external GPU Quadro P4000/Razer Core X Chroma is connected to the laptop computer via Thunderbolt 3 cable (It is necessary for me to use the Quadro P4000 and Nvidia 3D vision kit for 3D stereo display because of my daily work).

Thank you in advance.

nvidia-bug-report.log.gz (1.77 MB)

Screenshot from 2019-08-14 14-01-48.png

First of all, please add

Option "AllowExternalGpus" "true"

inside the OutputClass section of /usr/share/X11/xorg.conf.d/10-nvidia.conf
to allow the usage of the egpu for xorg. This doesn’t make it work because of the internal nvidia gpu taking precedence. For an easy way to change this, please check if your bios has an option to disable the internal nvidia gpu, e.g. switching graphics from “Hybrid/Optimus” to “Intel only”.

1 Like

Dear Generix,

Thank you very much for the quick turnaround!
Adding Option “AllowExternalGpus” “true” works to see the external GPU Quadro P4000 in ‘Nvidia-settings’, but the external monitor still does not respond. I found an option in BIOS to disable ‘Nvidia® Optimus™ Technology’ (i.e., only “Enable” to “Disable” but not “Hybrid/Optimus” to “Intel only”), but disabling this option ended up with no response from the external monitor. Attached is screenshots that I just took. Thank you again for your help and looking forward to hearing from you again.

nvidia-settings-after-modifying-10-nvidia-conf.png
nvidia-settings-after-disabling-nvidia-optimus-BIOS.png
nvidia-smi-after-disabling-nvidia-optimus-BIOS.png
image1.jpeg
image2.jpeg

Ok, this looks like the bios switch disables the integrated intel gpu which doesn’t help. Please put it back to “enabled” and create /etc/X11/xorg.conf with contents

Section "ServerLayout"
    Identifier     "layout"
    Screen      0  "nvidia" 0 0
    Inactive       "intel"
EndSection

Section "Device"
    Identifier     "intel"
    Driver         "modesetting"
    Option         "AccelMethod" "none"
    BusID          "PCI:0:2:0"
EndSection

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:20:0:0"
    Option         "AllowEmptyInitialConfiguration"
EndSection

Section "Screen"
    Identifier     "nvidia"
    Device         "nvidia"
EndSection

Then reboot.
The downside of this is that once you remove the egpu and want to use the notebook, you’ll have to remove/rename the config.

Dear Generix,

Oh my, thank YOU so much. It works!!
Ok, then let me remove /etc/X11/xorg.conf if I need to remove the eGPU and use the laptop computer.
Nvidia 3D vision kit (i.e., IR emitter) still does not work, but let me try to find out the solution!
(let me get back to you in case there is no luck :D)

Thank you very much again. I sincerely appreciate it.
image3.jpeg

Thinking a bit over your attempt to use 3D vision, this will fail in many ways currently.

  1. Most of all, Stereo requires compositing to be turned off in the Xserver but then Gnome won’t work. So you will have to switch to a different DE, maybe MATE or XFCE or KDE, possibly involving installing a different distribution.
  2. Mixing Stereo and non-Stereo capable monitors doesn’t work, so you will have to re-configure xorg.conf or the DE to only use the external screen.

Dear Generix,

Thank you so much for the continued support.
You are right. Updating /etc/X11/xorg.conf by adding the option “stereo” “10” to the Device section made Nvidia 3D vision emitter ‘green’, but disabling composite (i.e., adding the option “Composite” “Disable” to the extensions section) led to the login session crash (i.e., login loop). Let me try installing MATE or XFCE or KDE, and then switch to one of these. Hope one of DEs works to enable hardware stereo with the external GPU Quadro P4000 in Ubuntu 18.04 LTS. BTW, do I still have to use the modified xorg.conf (i.e., option “stereo” “10” to the Device section and option “Composite” Disable” to the Extensions section) no matter what non-GNOME DE works for 3D vision? (Sorry. I am not familiar with Linux/DE).

Let me give it a try to install non-GNOME DEs and then get back to you soon.

Thank you very much again for your great support!

Kind regards,
John

The changes to turn off the composite extension and turn on stereo will still have to be made but those DEs mentioned support non-composited DE, i.e. will not crash.

Dear Generix,

I managed to install MATE 1.22 in Ubuntu 18.04 LTS based on this recipe:

sudo add-apt-repository ppa:jonathonf/mate-1.22
sudo apt update
sudo apt install mate-desktop-environment

Choosing MATE Desktop session from login screen works well even if the change to turn off the composite extension was made in /etc/X11/xorg.conf. Unfortunately, however, 3D hardware stereo still does not work most likely due to mixing stereo (the external 3D vision ready ASUS monitor) and non-stereo (laptop screen) capable monitors, as you advised me earlier.

Would you be so kind and help me re-configure xorg.conf once again or the DE to only use the external monitor? Thank you very much in advance. BTW, I modified xorg.conf based on this recipe: https://www.schrodinger.com/kb/1287

Here my up-to-date xorg.conf is:

Section "ServerLayout"
    Identifier     "layout"
    Screen      0  "nvidia" 0 0
    Inactive       "intel"
EndSection

Section "Device"
    Identifier     "intel"
    Driver         "modesetting"
    Option         "AccelMethod" "none"
    BusID          "PCI:0:2:0"
EndSection

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:20:0:0"
    Option         "AllowEmptyInitialConfiguration"
    Option         "Stereo" "10"
EndSection

Section "Extensions"
    Option         "Composite" "Disable"
EndSection

Section "Screen"
    Identifier     "nvidia"
    Device         "nvidia"
EndSection 

Oh, BTW, besides 3D stereo, I got an error message right after MATE login (please have a look at the attachment).

Thank you very much again for your continued support! I look forward to hearing from you.

Kind regards,
John
MATE_login_error.png
Nvidia-smi-and-settings-after-MATE-login.png
nvidia-bug-report.log.gz (1.63 MB)
xorg-conf.png

The login error is about the indicator applet, to display date/time/weather/messages. Seems some needed packages haven’t been pulled in on mate install. Just remove and ignore for now.
The setup looks fine otherwise, just go to mate system settings->displays and disable the internal notebook display, then run
glxgears -stereo
from a terminal and report what happens.

Dear Generix,

The change to turn off the internal notbook display works to finally enable hardware 3D stereo with the external GPU Quadro P4000!! Thank you very much for great support!! :D Sincerely appreciate it.

Let me remove xorg.conf just in case if I need to only use the laptop computer in the absence of the external GPU, otherwise let me stick to current setting in Ubuntu 18.04 LTS - MATE.

Have a wonderful day!

Kind regards,
John

Dear Generix,

May I ask you one last question regarding MATE DE? I just realized that all menus, terminals, windows, etc have black boarders after installing MATE DE (Please have a look at the attachment). Do you happen to know how to disappear this?

Thank you very much again for helping me enable the hardware stereo! :) Have a nice Friday and weekend!

Kind regards,
John
nvidia-bug-report.log.gz (1.75 MB)

See if this fixes it:
http://www.webupd8.org/2015/11/fix-large-black-borders-around-header.html

Hi Generix,

Good to hear from you again!
Unfortunately, however, creating and modifying ~/.config/gtk-3.0/gtk.css is unlikely to work. I just tested this as well: The change to remove xorg.conf and then log in MATE DE works to disappear the black boarders. Let me search other recipes (otherwise let me just enjoy the black boarders :D)

Thank you again and have a nice weekend!

My guess, it’s a side-effect from disabling the composite extension. Installing a different DE on standard Ubuntu will only install some minimal packages, so manual installation is always needed (that’s also the reason for the Ubuntu flavors). Maybe try installing a different Mate theme for a start.

Hi Generix,

Installing the Xfce DE eventually figured out the black border issue!. The hardware 3D stereo with the Quadro P4000 eGPU also works very well!

Thank YOU very much again for the continued wonderful guidance how to figure all issues out!!

Kind regards,
John

1 Like

thank you so much for your suggestion, generix

adding
Option “AllowExternalGpus” “true”
worked for me