empty libC.so on trial installation

Hi,

I just installed trial 16.3 on Centos 6.6, without any problems.
When i tried to compile some weather model libraries, i got a problem :

/opt/pgi/linux86-64/16.3/lib/libC.so: file not recognized: File truncated

when i checked the lib file i got:

[wrftest@ANY ~/esmf]$ ll /opt/pgi/linux86-64/16.3/lib/libC.so
-r--r--r--. 1 root root 0 Mar 10 02:40 /opt/pgi/linux86-64/16.3/lib/libC.so

The installation did complain that it is not able to find 32-bit compiler, but i don’t need it, so i didn’t install it, and it continued to a successful end, once i said ok.


BR
Vlada

Hi Vlada,

“libC.so” no longer ships with the PGI compilers. It was the C++ runtime library for pgcpp which has been replaced with pgc++.

It’s unclear why the file exists on your system. Perhaps you applications build uses “touch” on the file?

Does you your application add libC to the link line? If so, you should remove it.

  • Mat

The Linux downloads of PGI compilers, other than the CDK, are strictly
32-bit only or 64-only. If you downloaded the PGI workstation product,
and it complained that you do not have 32-bit compilers, would suggest you
tried to install the 32-only product.

pgilinux-2016-163-x86_64.tar.gz (the 64-bit product).
pgilinux-2016-163-x86.tar.gz ( the 32-bit product)
pgicdk-163.tar.gz (both 32-bit and 64-bit products, if you have access to it)

so make sure you downloaded the 64-bit product, and are using the
64-bit product.

Add -m64 to your compile line to make sure you are using 64-bit compilers.

dave