Enable rdma without switch

Hi,

I’m trying to enable the rdma-capability between ConnectX-5 adpaters.

I equipped the adapters with two servers each and connected them with Infiniband.

I ran the OpenSM in one of the servers and i checked that it worked.

After this configuration, the ‘ibv_devinfo’ command didn’t work with the error message saying some files(libmlx4-rdmav25.so, libmlx5-rdmav25.so, librxe-rdmav25.so) do not exists.

Is there any way to solve this problem?

Thanks,

Wonsik

Hello Wonsik,

Thank you for posting your inquiry to the Mellanox Community.

This error message appears because the libibverbs package is missing from your system.

The libibverbs package contains the API required to interface with the ib_uverbs module.

This package can be installed via your distribution’s package manager, or automatically as part of the Mellanox OFED driver installation process.

To obtain the correct Mellanox OFED driver package for your distribution, see the following link:

https://www.mellanox.com/products/infiniband-drivers/linux/mlnx_ofed

For information on installing the Mellanox OFED driver, see the following link:

https://community.mellanox.com/s/article/howto-install-mlnx-ofed-driver

Best regards,

Mellanox Technical Support