Enable Wayland on TX2 with Jetpack 4.2

I’m trying to enable Wayland on the TX2 I’ve updated with Jetpack 4.2. If I comment out “WaylandEnable=false” in /etc/gdm3/custom.conf when I boot the TX2 is stuck at the end of the systemd startup output switching back and forth from a black screen every 1-2 seconds. Is there a way to boot with Wayland enabled?

bmanyu,

Let me check it on my side.

Hi bmanyu,

Sorry for late reply. We are still discussing this issue with our internal team.

Any update?

Thanks.

bmanyu,

Turns out this is still under test phase. Our team is working on it internally.

Please add this part to your device tree.

tegra_udrm: tegra_udrm {
		compatible = "nvidia,tegra-udrm";
	};

That did not work. I still was stuck at the end of the systemd startup output switching back and forth from a black screen every 1-2 seconds.

Hi bmanyu,

List enable Wayland steps for you reference:

  1. Update mutter:
sudo apt-get update
sudo apt-get install libmutter-2-0 mutter
  1. Enable Ubuntu Wayland Desktop:
(a) In /etc/gdm3/custom.conf set "WaylandEnable=true" (by default it'll be false)
(b) In /etc/modprobe.d/tegra-udrm.conf uncomment the line "#options tegra-udrm modeset=1"  (Remove # from the start of the line).
  1. Update below two file:
(a) In /etc/systemd/nv.sh change DISABLE_MESA_EGL="1" to DISABLE_MESA_EGL="0". 
(b) In /etc/systemd/system/nvargus-daemon.service replace "ExecStart=/usr/sbin/nvargus-daemon" with "; ExecStart=/usr/sbin/nvargus-daemon" ( Put ";" at the start of the line)
  1. Reboot device.

carolyuu,

That works. Thanks. Comments in one of the modified files confirm what WayneWWW said, that testing/development is still being done to support Wayland. Have you had any negative side effects from running this way?

tegra_udrm: tegra_udrm {
compatible = “nvidia,tegra-udrm”;
};

questions

  1. which file should I edit?
  2. how to build dts -> dtb in your build system?
  3. how to flash only dtb in TX2

Can you answer the questions above?

Hi,

You could know which dts file you are using by typing “dmesg |grep dts” on tegra and it would show the dts name.

As for question 2,3 please refer to L4T documentation on download center.There is a section for kernel customization. You’ll also need to download the kernel source code from download center.

Thanks. It works!!

then I have questions.

In the Above Answer.
I found that (2) was not necessary.

2. Enable Ubuntu Wayland Desktop:
(a) In /etc/gdm3/custom.conf set "WaylandEnable=true" (by default it'll be false)
(b) In /etc/modprobe.d/tegra-udrm.conf uncomment the line "#options tegra-udrm modeset=1"  (Remove # from the start of the line).

What is the purpose of the codes works?