Enabling SLI makes all the windows start flashing on Ubuntu 14.04

Still no luck…

Sli “on” on opensuse 13.2 beta makes the system unbootable, editing the xorg.conf file to disable sli in the recovery mode cli makes the system bootable once again.

The same option on manjaro with either 3.10 or 3.16 kernels doesen’t make any change on the system but that’s because the second card isen’t being used at all, not even the memory(0% use).

So far ubuntu gnome is where SLI is closest to work, sisnce there some use of the second card during games, but the windows flashing constantly is just too annoying for everyday use.


Yeah M4xP4yne… you’re going to have to wait until NVIDIA updates their drives for improved SLI support in Linux. As noted earlier though, SLI hasn’t been worked on in Linux since 2008… as ekrboi noted? Using one GPU per monitor works good for performance (each GPU renders its own screen) but trying to use multiple GPU’s on a SINGLE monitor does not work unless you’re using an SLI Profile with “GLDOOM3” set to “true” on any ID Tech 4 Engine game.

So yeah… pretty much just read the driver notes and hope for SLI performance updates… until then? Just leave it off. The second card will only sap power and not do anything.

I even asked on PlayOnLinux if there’s a way to enable Swapping on WINE or any SLI / Mosaic support… nope. None.

So yeah… seems like no matter what we use? She’s boned. NVIDIA needs to fix their drivers. Kernel updates won’t make a difference… nothing will… only NVIDIA drivers can.

Maybe so, but it’s just what I’m used to and what I like tbh. Ubuntu’s Unity is pretty decent… but it definitely is getting shady with Amazon ads and stuff… I’m not really a fan of that and that’s why before I ended up sticking with XFCE and Cinnamon… because I love the taste of… Cinnamon. :P