Unity doesn't start on Ubuntu 16.04 when SLI=on

Greetings nvidia / Linux experts!

I’ve recently built a dedicated Linux machine around the AMD Ryzen platform and having some problems making SLI work.

Some information about the relevant components:

  • Gigabyte X370 mainboard (GA-AX370-Gaming5) & Ryzen CPU
  • 2x GTX 970 GPUs
  • Ubuntu 16.04 with kernel 4.10.4
  • Nvidia driver 378.13

Facts:

  • SLI works fine under Windows 10 on the same machine
  • Everything works fine under Linux with sli=off: tried a few games from Steam, no particular problems

Where it falls apart:

  • Use nvidia-xconfig --sli=on (& restart)
  • Log in screen shows up
  • After entering password, the window manager doesn’t start and I just get my profile’s wallpaper and mouse pointer
  • I can switch to other tty terminals without any problems, machine is not crashed
  • Installed xfce, switched to it at the lightdm screen: I can log in and get an xfce desktop
  • nvidia-settings application indicates SLI enabled
  • Started a couple of games: performance is very poor (<5fps), so clearly it’s not happy

As I’m a bit of a Linux newbie I didn’t know where to start looking for diagnosing this and X is a complicated beast, suggestions welcome :-)

(I also ran the nvidia-bug-report script so got that available.)
nvidia-bug-report.log.gz (681 KB)

Screenshot from 2017-05-04 21-08-24.jpg

Bump :-)

No replies so far, should I assume that SLI + Linux isn’t really supported?

Helo Rob, you cerate a xorg.conf arquive in /etc/X11?

control+alt+f1

sudo /etc/init.d/lightdm stop

sudo nvidia-xconfig

and reboot

Go to /etc/X11 and configure xorg.conf

Option “SLI” “string”

This option controls the configuration of SLI rendering in supported configurations.

Value Behavior

0, no, off, false, Single Use only a single GPU when rendering
1, yes, on, true, Auto Enable SLI and allow the driver to automatically select the appropriate rendering mode.
AFR Enable SLI and use the Alternate Frame Rendering mode.
SFR Enable SLI and use the Split Frame Rendering mode.
AA Enable SLI and use SLI Antialiasing. Use this in conjunction with full scene antialiasing to improve visual quality.
AFRofAA Enable SLI and use SLI Alternate Frame Rendering of Antialiasing mode. Use this in conjunction with full scene antialiasing to improve visual quality. This option is only valid for SLI configurations with 4 GPUs.
Mosaic Enable SLI and use SLI Mosaic Mode. Use this in conjunction with the MetaModes X configuration option to specify the combination of mode(s) used on each display.

Hi Platao,
I didn’t have to edit the xorg.conf file by hand as this is done correctly by the nvidia-xconfig command.

I however did check that the SLI parameter was enabled in it:

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
Option “SLI” “on”
SubSection “Display”
Depth 24
EndSubSection
EndSection

In the meantime I reached out to customer support through the main nvidia site.

No replies so far.

-Rob

Hi Rob

Did you manage to get the SLI working? i have the same problem with Unity. i have not check to see if it works with CUDA in terminal environment yet but i was wondering if you were able to get it to work.

my system is

Asus Prime x370-pro with Ryzen 7 1800
2 x GTX 1080 Ti
Ubuntu 16.04 with kernel 4.10.4

Hi Pooyaj,
short answer is no, SLI is still not working but here’s the situation:

I discovered that Nvidia will not try to reproduce or work on any problems that are happening on motherboards that are not part of their qualified SLI list:

http://www.geforce.com/hardware/technology/sli/motherboards

If your motherboard is not on that list, you’re out of luck. I tried to get Gigabyte to add my own motherboard there (X370-Gaming5) but their support team don’t want to do any effort to add their “gaming” boards to that list. Nvidia told me it’s up to the vendor to submit the board for qualification, Gigabyte don’t care… (last Gigabyte board for me)

As I have a second computer which has an Asus Intel based motherboard that’s on the Nvidia SLI certified list I tried the same SLI setup on it and it’s also not working with the same behavior.

This got me further as the Nvidia Tech support accepted to raise a defect and have the engineering team look into it.

That’s where I stand now: waiting for Nvidia to look into it / fix it at some point. This was several weeks back so I assume it will take some time to get resolved.

Regards,
Rob

Please run nvidia-bug-report.sh and attach output file to your post or gist.github.com.

I’ve already provided the bug report to the Nvidia support team.

Do you have any need for it or is it out of curiosity? :)

This thread wouldn’t have surfaced if mailing it to support had brought up anything usable, would it?

Indeed, I’m still hoping someone will look into it as clearly it has nothing to do with the Ryzen system.

I’ve attached the bug report file to the post. Please note this was taken on a different Intel based system with different graphic cards as Nvidia wouldn’t look into the problem on the Gigabyte board.

Setup was done from a fresh Ubuntu 16.04 installation. Patched, installed latest Nvidia driver as requested by Nvidia tech support. Can log in this time but graphical artefacts appear everywhere on the desktop.

Performance in some games I tried is very bad with lots of stuttering and vastly inferior to a single card.

Hope this provides some insights.

Regards,
Rob

Can you try iommu=off as kernel parameter?

Just tried it on both computers with similar results. On the AMD machine the desktop looks ok with a little blinking from time to time but it’s using Gnome.
On the Intel computer with the standard Ubuntu installation I still get graphical artefacts/blinking when moving windows around on the desktop.

For the sake of comparison I started a game (The Talos Principle) and benchmarked with SLI on and off.

Computer 1:

  • SLI ON: 24.5fps
  • SLI OFF: 53.5fps

Computer 2:

  • SLI ON: 25.3fps
  • SLI OFF: 107.3fps

Yes, unfortunately the results are not inverted :-)

Thanks for the suggestion though…

Regards,
Rob

We are tracking this issue under 1929896 .
Is the all games are affected due to this issue wit sli? Make sure you have sli certified MB. Is the artifacts is effect of poor perf ? Or Both issues are different ? Is the issue reproduce with bare X? Can you please check older drivers to find regression for both issues.

Hello,
i also have issues with nvidia-xconfig --sli=auto. I am running opensuse tumbleweed with kernel 4.11.6-1-default. My compi is a new build from april by myself.

-Asus Prime X370 PRO
-Ryzen 7 1800X
-32GB DDR4
-2x KFA2 GTX 1080
-bequiet power supply 700W
-bequiet case dark base pro 900 ??
-Nvme SSD Samsung EVO 960 500 GB ( opensuse tumbleweed )
-Other SSD with steamos
-Other SSD with windows 7 professional
-Other SSD, raid1 hdd 1TB, nfs drive 12 TB
-nvidia driver is 381.22 on opensuse tumbleweed and steamos

When i bought the second gtx 1080 a few weeks ago for faster working with blender, i thought … why not try to use sli for gaming. So i typed nvidia-xconfig --sli=auto in a console, restart X server, but failed. I switched to console and typed in “X -verbose 6 :0 &”, but also failed. I read something with failed DMA in the logs. I modified steamos (brewmaster) within opensuse tumbleweed to use sli, but same error on steamos. At last i tried SLI on the windows 7 professional installation to see if there is a hardware issue, here it works fine. Blender works fine with both cards under linux.

Best regards
Uwe

nvidia-bug-report.log.gz (261 KB)

The nVidia incident ID# is 170504-000497 if you’d like to follow internally.

I have already spent too much time diagnosing this issue on my own, especially given I own no less than four nVidia boards and two computers where it doesn’t work under Linux with exactly the same behaviour.

To be clear: both systems work with SLI enabled under Windows. No problems at all.

The results below are exactly the same on both computers:

  • Game performance is very poor with SLI enabled. Framerate is slower than without SLI.
  • Desktop artifacts can be observed when SLI is enabled as seen in attached picture.
  • Both issues above occur when SLI is turned on and disappear when SLI is turned off.
  • On both systems Ubuntu 16.04 LTS was installed fresh with only the nVidia driver as requested by the nvidia support, so I don’t know what you mean by ‘bare X’.
  • Mainboard is on the official SLI supported list.

And finally, no I’m not going to try older drivers: regression testing is nVidia’s responsibility not the customer’s. Do you want me to fix the code myself maybe? Oh wait, I can’t do it because it’s not open source so we’re screwed waiting for nVidia to maybe do something in a few months.

Sorry for sounding negative but I haven’t seen any progress in two months and I’m being asked to try more things. What about you trying to do something for a change?

RobSan, Never mind. We are working on this issue. Regression info I just requested if possible. Anyway internally we will find that.

Is this still an open issue?
I was unsuccessful to turn sli=on with two 1080 ti cards, msi 370 carbon and Ubuntu 16.04.
Tried all available drivers.

I had the same problem as this thread.
Computer booted up to login screen.
After login box disappeared, unity did not start up.

It’s unfortunately not fixed yet.

We have fixed desktop corruption issue when sli on. Fix will be available in upcoming r375 and r384 drivers.

sli performance issue we are still investigating.

Hi Sandip,
thanks for the update. I can confirm that the desktop issues are completely resolved both computers.

SLI performance is as you mention still a problem.

Let me know if I can help.

Regards,
Rob