SLI issues on both 346.47 and 349.12 (GTX 980, Ubuntu 14.10 & 15.04)

I recently switched from AMD 6970 Crossfire to GTX 980 SLI. I’ve been having a hard time getting SLI to work at all in Linux; in all other SLI modes than “sfr” I get terrible artifacts and painting issues, where dragging a window in Ubuntu Unity desktop keeps drawing several previous positions (and tooltips) on alternating frames. The result is a really flashy screen. Curiously, when logging out the dimming overlay displayed by Unity will clear all of these artifacts.

When I use SLI in “sfr” mode, SLI seems to work, but the highest rate I can get from xrandr and nvidia-settings is 85 Hz, despite having a 144 Hz display (Asus ROG Swift PG278Q). Xrandr refuses to set the rate above 85 Hz when this mode is enabled. (I also see a horizontal black bar in the middle of screen when I log into a desktop session, opening a terminal seems to be enough to get rid of it.)

Turning SLI off, logging out and logging back in again results in a clean desktop with 144 Hz rate automatically chosen.

I initially tried to get this setup working with SLI on Ubuntu 14.10 with the latest stable drivers, then upgraded to the latest beta driver, and finally upgraded to Ubuntu 15.04 beta due to finding some mentions of a similar sounding bug being fixed in compiz between the two releases. Sadly that didn’t help.

I tried to find other posts related to this issue, but I was unable to find anything recent. might be the same issue based on the description in the first post.

I’m happy to answer any further questions and helping out solving the issue. I’m not (yet) intimately familiar with the graphics stack on modern Linux but I’m willing to learn and help.

nvidia-bug-report.log.gz (147 KB)

This does not answer your question, but even when the driver gets better for the 980 cards and sli it will not be worth your efforts and time anyway.
I have 4 780 Kingpins and no matter what settings I use sli simply does not work better than a single card. My fps with sli enabled (sfr works best) in games like boarderlands (unreal engine) is 60 fps. If I change to just one 780 kingpin I get over 100 fps. So even if the 980’s driver gets better you will not like the sli results at this time.

Yep. SLI in Linux is pretty much useless if not worse than useless since The_Real_Cuda’s example is spot on. I have 3 970’s (2 580’s before that) and I just don’t enable it in Linux and just run on a single GPU. I use to think it helped in base_mosaic mode but after much testing and more reading I came to the conclusion that I was wrong unfortunately.

It is pretty much THE reason I still do most of my gaming in Windows. Other than FC4, all the games I have played in the last 6 months are available on Linux and I still had to play on Windows in order to actually use all of my GPU’s to play games in surround (5760x1080 resolution).

This won’t get fixed I don’t think. OpenGL + multi GPU is apparently a big PITA, or so I have read. Vulkan will support it though, so hopefully once the Vulkan games start coming out this will no longer be a problem. For now though, if having it enabled is giving you problems then just turn it off since at best it won’t do squat for you and at worse you will get worse FPS than using a single card.

So if I understand this correctly, SLI DOES NOT WORK IN UBUNTU ? Correct ? I mean all this

nvidia-xconfig --multigpu=on


nvidia-xconfig --sli=on

does what exactly ? I mean nvidia-settings see all available GPUs, but one is idle temperature is not moving on slave unit, yet master is moving as it should.

Yep, well almost, not just Ubuntu, SLI doesn’t really work in Linux period. SLI was implemented in Linux for games built using idTech4 engine (Doom3, Quake4, etc…) and has not been updated since AFAIK. To even use it for those games you have to create your own “SLI profile” for it and even then scaling wasn’t exactly good from my understanding.

So it is basically like in Windows where normally when a game comes out that doesn’t have an SLI profile in the drivers yet then usually a single card will perform better than with SLI enabled until the game is optimized for multi gpu configs and a proper SLI profile is released for the driver.

There are some cases where forcing AFR2 can help improve framerate in games (like in windows for games without SLI profiles) but scaling is still not usually very good and then you run into issues with the desktop like OP described or glitchy/flashing windows as I’ve seen others mention. Then there are cases like my setup where I have 3 monitors and enabling SLI will ONLY allow one monitor to work at a time(this is documented in the driver docs).

BUT! with the onslaught of GPU crushing AAA titles coming to Linux I don’t think they will be able to ignore SLI for too much longer, though we may be stuck until Vulkan comes out and games start using it. Then the DE’s and other software that have problems with it enabled are just going to have to fix their stuff.

TL;DR - short answer, don’t use SLI on Linux.

So, same boat GTX980 2 way SLI. I LOVE UBUNTU and STEAM.

So no SLI for us. I mean one 980 more than enough to run ANYTHING really but. What a waste.

Also I mean between no SLI and Blizzard not moving with getting all it’s games or at list WoW to Linux I need to stick around with Windows for little bit longer then. Sucks but what can you do.