Enabling USB 3.0 on Jetson TK-1 with Grinch kernel 21.5

We are using Tegra-Jetson TK1 processor with Ubuntu 16.04 and Grinch kernel 21.5. In order to activate USB 3.0 on it, the following steps were performed:

  1. In “/boot/extlinux/extlinux.conf” file “usb_port_owner_info=0” was changed to “usb_port_owner_info=2”
  2. “usbcore.usbfs_memory_mb=1000” was added to the end of line
  3. System was rebooted

When the system was up, the USB port couldn’t detect any hardware device that was connected to it. Even if step 2 was not performed, same observation was made. A similar procedure is also outlined http://elinux.org/Jetson/Cameras and on other posts on this forum as well.

Any quick help in this regard will be greatly appreciated.

hi Naveen,
Please try to apply your changes to kernel/arch/arm/mach-tegra/board-ardbeg.c

Hey, I’m planning on using the TK1 soon with L4T 21.5. I’m assuming your kernel is L4T and not the Grinch, since I can’t find any information on Grinch 21.5. Just wanted to check if you ended up solving the problem, and if so, how?

Hi thebluser2, please follow http://www.jetsonhacks.com/2014/11/08/jetson-tk1-linux-tegra-l4t-21-1-enable-usb-3-0/ to enable usb3.0 on TK1

Excellent link, thanks!