Jetson TK1 USB 3.0

I have some issues with the USB port on the TK1. Using a high-bandwidth USB 3.0 camera, I can sometimes get the device to begin sending frames the first try. When it doesn’t work, it shows that the device has disconnected and I have to un-plug and re-plug the cable to get it back. If I try this through a USB 3.0 hub, it will disconnect the hub as well and doesn’t come back after an unplug without a reboot.

I have the suspend workaround set in my rc.local:

sudo bash -c ‘echo -1 > /sys/module/usbcore/parameters/autosuspend’

This camera works without issue on the desktop. My guess is that it is not being fed enough power, or the power is inconsistent.

Please be aware that you have to explicitly unlock the USB 3.0 Port on the Jetson, it is set to work as normal USB 2.0 Port by default.

See here : https://devtalk.nvidia.com/default/topic/751916/embedded-systems/microsoft-kinect-with-jetson-tk1/post/4239031/#4239031

I got the USB 3.0 enabled by following the Quick Start Guide for flashing the system found here:

https://developer.nvidia.com/sites/default/files/akamai/mobile/docs/l4t_quick_start_guide.txt

Please note that you need to change the jetson_tk1.conf file before flashing the system to enable USB 3.0. This is documented in the release notes, but also with comments in the file. Simply commenting one line out and another in is sufficient.

Yes, I have enabled 3.0 mode and it’s visible in lsusb:

$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I have several cameras that work flawlessly on a desktop (Ubuntu 14.04), but only intermittently with the TK1. I have also tried several powered and un-powered USB 3.0 hubs in between.

Have you tried disabling auto suspend http://elinux.org/Jetson/Cameras#Disabling_USB_auto-suspend?

Yes, see my first post.

Also note that you probably have to unplug and replug the USB device after disabling the auto-suspend feature.

It’s my understanding that the change won’t be applied to already plugged-in devices.

(Correct me if I’m wrong!)

I added this to my .bashrc and it made me enter my password at boot every time which is LAME. Here’s a better way to keep autosuspend off:

http://jacksonkr.com/content/jetson-tk1-disable-usb-autosuspend