Jetson USB Camera Hang

We have facing a strange problem when we are using USB camera in Jetson TK1.
Issue

  1. We external USB 3.0 HUB on Jetson and connected 2 USB 3.0 camera.
  2. We are getting 5MP frames from both the camera and encoding it to H264 and streaming it over Ethernet using gstreamer command.
  3. While doing so after 10 min we got kernel opps and device hangs.
    Did any one faces this kind of error? Is there any known issue or limitation in USB 3.0 or H264 encoder?

I have pasted the error below,

[57708.062601] uvcvideo: Failed to resubmit video URB (-1).
[60654.282051] Unhandled fault: imprecise external abort (0x1406) at 0x00000000
[60654.285137] MSELECT error detected! status=0x10
[60654.285154] ------------[ cut here ]------------
[60654.285156] kernel BUG at drivers/platform/tegra/hier_ictlr/hier_ictlr.c:54!
[60654.285158] Internal error: Oops - BUG: 0 [#1] PREEMPT SMP ARM
[60654.285169] Modules linked in: dm_crypt dm_mod rfcomm bnep bluetooth rfkill nvhost_vi
[60654.285173] CPU: 0 PID: 3660 Comm: kworker/0:1 Tainted: G W 3.10.40-g868897a #1
[60654.285182] Workqueue: host_syncpt syncpt_thresh_cascade_fn
[60654.285184] task: d2e35080 ti: cfe3c000 task.ti: cfe3c000
[60654.285189] PC is at tegra_hier_ictlr_irq_handler+0x38/0x40
[60654.285192] LR is at tegra_hier_ictlr_irq_handler+0x38/0x40
[60654.285194] pc : [] lr : [] psr: 60030193
[60654.285194] sp : cfe3dc38 ip : 00000000 fp : c0d0a198
[60654.285196] r10: 00000000 r9 : 00000000 r8 : cfe3c000
[60654.285198] r7 : cfe3dcd8 r6 : 0000009f r5 : c0bcb910 r4 : d70ca780
[60654.285199] r3 : 00000000 r2 : 00010100 r1 : 00000000 r0 : 00000023
[60654.285202] Flags: nZCv IRQs off FIQs on Mode SVC_32 ISA ARM Segment kernel
[60654.285204] Control: 10c5387d Table: 8f99006a DAC: 00000015
[60654.285206]
[60654.285206] PC: 0xc0622f74:
[60654.285213] 2f74 ebf80968 e1a01004 e3a02000 e1a00005 ebf818d2 e1a00004 e3a01000 ebf8195a
[60654.285220] 2f94 e1a00004 e59f1008 e3a02000 e8bd4070 eaf81886 c0ce9498 e92d4000 e8bd4000
[60654.285227] 2fb4 e3a00004 e12fff1e e92d4008 e92d4000 e8bd4000 e1a00001 ebf7e0eb e590300c
[60654.285233] 2fd4 e5931060 f57ff04f e3510000 1a000001 e3a00001 e8bd8008 e59f0004 eb07bd62
[60654.285239] 2ff4 e7f001f2 c0a9183c e92d40f8 e92d4000 e8bd4000 e1a06001 e1a07002 e3a01c02
[60654.285246] 3014 e3a02000 e1a04000 ebf7e8d6 e2501000 0a000012 e2845010 e1a00005 ebf28927
[60654.285252] 3034 e3500000 e5860000 0a000016 e3a01c02 e1a00004 e3a02001 ebf7e8ca e2501000
[60654.285259] 3054 0a00000b e1a00005 ebf2891c e3500000 e5870000 0a000010 e3a00000 e8bd80f8

Thanks in advacne for your help.

Hi Jeslin,

There is a new TK1 firmware for similar case, please refer below link to update it:
https://devtalk.nvidia.com/default/topic/936302/jetson-tx1/support-for-multiple-high-resolution-usb-3-0-cameras-/post/4928235/#4928235

I’m not sure whether it can help more, but it’s better to estimate the USB 3.0 bandwidth with the device you are using first, and please make sure set CPU to max freq to prevent event ring full problem.

Besides, if only do the H264 encoding on device, not do the streaming via ethernet, could the device hang?

Thanks