enabling vsync (no tearing) on TK1

Has anyone managed to enable VSync on jetson TK1?

On a regular desktop I’m able to enable VSync by doing:

nvidia-settings -a SyncToVBlank=1
export __GL_SYNC_TO_VBLANK=1

After setting this the tearing goes away.

On Jetson Tk1 however, we don’t have the “nvidia-settings” application.

To my understanding both X and OpenGL need to have VSYNC enabled to avoid tearing.

Hi, Jimmy Pettersson,

We have described how to enable/disable vsync in https://devtalk.nvidia.com/default/topic/759888/-jetson-tk1-vertical-sync-and-triple-buffering/?offset=7#4608645

We believe SyncToVblank=1 by default, so tearing issue may be due to something else.
Would you please describe your use case where this tearing is observed ?

Thanks