Enter OEM interface after reboot

Enter OEM interface after reboot.


My JP5.0.2 in orin devkit.

Hi jiangyinghao,

What’s the exact problem about this?
System configuration would be showed up to set time zone, username, password…etc after you flash the board.

I’ve configured these before, used the “tools/l4t_create_default_user.sh” script to create a system user in rootfs, and then burned the system image into Orin devikit, the OEM interface will no longer be displayed and will go directly to the desktop. Most of the time this is done directly to the desktop, but there are exceptions to this. Restart will occasionally re-appear to the OEM interface, preventing direct access to the desktop. I would like to ask if the “tools/l4t_create_default_user.sh” script did not automatically skip launching the OEM interface when creating the user? Why does this happen occasionally when you restart or disconnect the power and then power it on again? Can you help me troubleshoot it? Thank you. Here is the code to automatically log in and skip the OEM interface launch in the “tools/l4t_create_default_user.sh” script.

I compared logs that can automatically log in to the desktop normally with logs that cannot log in to the desktop normally this time.I don’t know whether it can help you analyze the problem. I call it normal that you can automatically enter the desktop, and abnormal that you cannot normally enter the desktop, that is, you enter the OEM interface. In the case of the same file system image, only a few devices restart and the OEM interface appears.

Under normal conditions:

Abnormal conditions:

Try to attach full log as text file. Do not just post some screenshot.

Hi jiangyinghao,

What’s the steps you flash the devkit? (flash.sh or SDKM?)
System configuration should only appear once after you flash the board.

For autologin feature, you can just set them through:
system settings->user accounts->click “unlock”->enable “automatic login”

Under normal conditions:
boot.log (107.3 KB)


I used the “tools/l4t_create_default_user. sh” script to create a system user in rootfs. This script will automatically log in and skip the oem interface.

I customize rootfs, and then generate images through flash scripts and burn them in.

Another point is that after entering the OEM interface, it occurs after the restart. Before the restart, the OME interface has been configured to skip. I also know that the OEM is only started once, so it is really started again. I want to know why this startup is happening?

Abnormal conditions:
dmesg (96.7 KB)

Did you follow the instruction here running l4t_create_default_user.sh before you flash the board?
Flashing Support — Skipping oem-config

yes,i use
/tools/l4t_create_default_user.sh -u $userName -p $userPasswd -a --accept-license -n $hostName

Do you connect other device (e.g. nvme) on your board?

So, “System Configuration showed up after restart” happens occasionally on the same board?
This issue could be reproduced by reboot many times?

  1. No other equipment is connected;

2, it can also happen on the same equipment;

  1. I don’t understand the third question. At present, we have five devices, three of which have this phenomenon.

These three devices will get this issue (System Configuration show up) at every reboot?

1, not every restart, only one restart occurs this problem;

  1. After following the configuration steps prompted by OEM again, there will be two users in the system. One is created previously, and the other is created as prompted by OEM.

You look at my abnormal log, can you find clues from the log? Why did this reboot go to OEM when it was used well before?

Could we confirm that when everytime this error happened, it always have “EXT4-fs recovery complete” log ?

Even if there are no errors, this log will have “EXT4-fs recovery complete”